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Chapter 8: The Utilities Menu
The Utilities menu contains tools for maintaining and restoring the
quality or integrity of data, for importing and exporting information from
other programs, and for moving data files to and from different directories on
your computer and other computers.

BACK UP HERD
Backing up your data files is very important. Therefore, in addition
to Cow Sense offering this utility every time you exit the program or prior to
major events such as Run New Cycle, Cow Sense makes the task easy to do
from the Utilities menu. Get in the habit of backing up your files often. Data
files become corrupted, hard disks crash, lightning strikes—disasters happen
without warning. Backing up is like crop insurance for your database, but it
costs only a couple minutes of your time.
You can back up any of your cow sense herd databases at any time.
When you run the backup utility, Cow Sense looks for the sequence number
of the last backup of the current herd, increments it, and copies the current
herd database to the herdsbak directory with the new sequence number as the
extension. This way, Cow Sense keeps track of your backups and you can see
what the backup history is for any given herd. Further, you can back up to
another media (floppy or Zip drive, for example) or to another hard drive.
You may also rename your backup file.
To create a back up of your database(s), select Utilities > Back Up
Herd from the main menu bar. Cow Sense will display a Back Up Herd
window (see Figure 8-1). Cow Sense will offer you a name for the backup
using a consecutive sequence number as an extension, and default to the
c:\cowsense\herdsbak directory.
Navigate in this window the same
way you would navigate in any
Windows directory tree environment
if you want to change the name or the
folder to which you want to store the
backup. Click the OK button to
proceed.

TIP: BACK

UP TO A MEDIA

THAT YOU CAN TAKE

“OFF

SITE ” TO PROTECT YOUR FILES
FROM SUCH DISASTERS AS
FIRE .

COW SENSE

COM-

PRESSES DATA ON BACKUP
AND IT WILL SPAN DISKETTES
AUTOMATICALLY .

FIGURE 8-1.
THE BACK UP HERD
WINDOW .

178

Chapter 8

NOTE: RESTORING

WILL

OVERWRITE THE EXISTING
SAME -NAME HERD FILE WITH
THE BACKUP YOU CHOOSE TO
RESTORE .

YOU

CANNOT

UNDO THIS OPERATION. IF
YOU MADE CHANGES TO THE
HERD FILE SINCE THE LAST
BACKUP , RESTORING THAT
BACKUP WILL OVERRIDE
THOSE CHANGES. BACK UP
THE CURRENT HERD BEFORE
RESTORING IT.

FIGURE 8-2.
THE RESTORE HERD
WINDOW .

FIGURE 8-3.
THE REPAIR HERD

WINDOW .

Remember, when you back up to another directory or folder on your
hard disk you will be protecting against user file error or data file corruption,
but you will not be protecting against equipment failure or other disasters;
that is why it is important to frequently back up to an off-source media such
as floppies, Zip disks or tapes.

RESTORE FROM BACKUP
The Restore Herd from Backup utility essentially works like the
Backup utility, only in reverse. When you use this utility, Cow Sense restores
the selected backup file to the c:\cowsense\herds directory and it gives the
file a .hrd extension. When you restore a herd, it automatically becomes the
default herd. Also when you execute this utility, you will overwrite the
current herd file with the herd file from which you are restoring, so use
caution.
The file names in the
source and destination directories
must match. If a destination herd
already exists, the Restore Herd
function will restore to that herd.
If a destination herd does not
exist, the Restore Herd function
will create a herd with that file
name and restore to that herd.
To restore a file, select Utilities > Restore from the main menu bar.
Cow Sense first warn you that you will overwrite the current herd file. Click
the OK button to continue. Cow Sense will display a Restore Herd window
(see Figure 8-2). The default folder for backups is c:\cowsense\herdsbak.
Navigate in this window the same way you would navigate in any Windows
directory tree environment if you
want to change the name or the
folder from which you want to
restore a backup. Highlight the
file you want to restore and click
the OK button to proceed. Then
click the Yes button in the subsequent warning boxes to verify the
Restore command.
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REPAIR HERD
Over time, your database will collect unnecessary information,
which takes up disk space. The Repair Herd option can help you recover
unused disk space. Also, sometimes, power outages, or other unknown
interruptions can corrupt data files. While the best insurance against data
file corruption is to frequently back up your herd, you may also be able to
recover damaged files with the Repair Herd command.
To use this utility, select Utilities > Repair Herd from the main
menu bar. Cow Sense will display a Repair Herd window.
The File Name box will display data files (those with a .hrd extension). The Directory box will display the Cow Sense default directory
(c:\cowsense\herds). If you have data files in a different directory, you can
navigate to that directory using standard Windows directory-tree protocol.
Select the data file you want to restore in the File Name box. Click the
Repair Herd button to proceed. Cow Sense will display a success message
after it is finished with the utility.

TRANSFER DATA
Cow Sense adds an extra level of control by allowing you to export
and import data to and from other software programs.

EXPORT
Cow Sense lets you export data to other programs, such as databases,
spreadsheets, charting and statistics packages to give you virtually limitless
analytical and reporting potential. Cow Sense exports all fields and field
titles from calf records, cow records, bull records and treatment records to
tab-delimited text files in the c:\cowsense\export directory. Also, Cow Sense
has a Save-to-Export button (see item J in Figure 5-1) on all report forms that
sends data from the report directly to a tab-delimited text file (where the
TAB key stroke is the separator that sequesters data into individual parts).
Refer to the Save to Export section of Chapter 5 for more information in
using this button. Most software products that have import capabilities can
handle tab-delimited text files.
This Production Cycle
Use this utility to export only calf records in the open production
cycle. To access the current Production Cycle export utility, select Utilities >
Transfer Data > Export > This Production Cycle from the main menu bar.

THE SAVE -TO -EXPORT
BUTTON .

LOOK FOR THIS
COW

BUTTON ON MOST

SENSE

REPORTS TO EXPORT

THAT REPORT DATA DIRECTLY
TO A TAB-DELIMITED FILE.
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Cow Sense will display an Export File Name
window (see Figure 8-4).

FIGURE 8-4. THE EXPORT
FILE NAME BOX.

It will give a default name of
You can overwrite that file name
if you wish. After you’ve established a file
name, click the OK button and Cow Sense will
begin exporting calf data to the
c:\cowsense\export directory. If you already
have a text file with the same name as the file
you’re exporting, Cow Sense will give you a warning and allow you to either
replace the existing file, append the new record to the existing file, or change
the file name. When Cow Sense is finished exporting, it will display an
Export Finished window telling you the number of records it exported, the
name of the export file, and where to find it.
THISPROD.TXT .

All Calves
The All Calves export utility exports all calf records in all production cycles for the open herd. To access the All Calves calf data exporting
utility, select Utilities > Transfer Data > Export > All Calves from the
main menu bar. Cow Sense will display an Export File Name window (see
Figure 8-4).
It will give a default name of ALLCALVES .TXT . You can overwrite that
file name if you wish. After you’ve established a file name, click the OK
button and Cow Sense will begin exporting calf data to the
c:\cowsense\export directory. If you already have a text file with the same
name as the file you’re exporting, Cow Sense will give you a warning and
allow you to either replace the existing file, append the new record to the
existing file, or change the file name. When Cow Sense is finished exporting,
it will display an Export Finished window telling you the number of records
it exported, the name of the export file, and where to find it.
Cows
The Cows export utility exports all cow records in the open herd. To
access the cow data exporting utility, select Utilities > Transfer Data >
Export > Cows from the main menu bar. Cow Sense will display an Export
File Name window (see Chapter 8-4).
It will give a default name of COWS.TXT . You can overwrite that file
name if you wish. After you’ve established a file name, click the OK button
and Cow Sense will begin exporting cow data to the c:\cowsense\export
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directory. If you already have a text file with the same name as the file you’re
exporting, Cow Sense will give you a warning and allow you to either
replace the existing file, append new records to the existing file, or change
the file name. When Cow Sense is finished exporting, it will display an
Export Finished window telling you the number of records it exported, the
name of the export file and where to find it.
Bulls
The Bulls export utility exports all bull records in the open herd. To
access the bull data exporting utility, select Utilities > Transfer Data >
Export > Bulls from the main menu bar. Cow Sense will display an Export
File Name window (see Figure 8-4).
It will give a default name of BULLS .TXT . You can overwrite that file
name if you wish. After you’ve established a file name, click the OK button
and Cow Sense will begin exporting bull data to the c:\cowsense\export
directory. If you already have a text file with the same name as the file you’re
exporting, Cow Sense will give you a warning and allow you to either
replace the existing file, append new records to the existing file, or change
the file name. When Cow Sense is finished exporting, it will display an
Export Finished window telling you the number of records it exported, the
name of the export file and where to find it.
Treatment Headers
The Treatment Headers export utility exports a list of treatments—
products and procedures). Select Utilities > Transfer Data > Export >
Treatment Headers from the main menu bar. Cow Sense will display an
Export File Name window (see Figure 8-4).
It will give a default name of TREAT _ HE.TXT . You can overwrite that
file name if you wish. After you’ve established a file name, click the OK
button and Cow Sense will begin exporting bull data to the
c:\cowsense\export directory. If you already have a text file with the same
name as the file you’re exporting, Cow Sense will give you a warning and
allow you to either replace the existing file, append new records to the
existing file, or change the file name. When Cow Sense is finished exporting,
it will display an Export Finished window telling you the number of records
it exported, the name of the export file and where to find it.
Treatment Details
The Treatment Details utility exports individual and herd treatments
for calves, cows and bulls as long as you specify that information in the
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respective Calf, Cow, and Bull tabs of the Enter Data > Treatments > Treat
Cattle option (see Chapter 4). To access the herd treatments data exporting
utility, select Utilities > Transfer Data > Export > Treatment Details >
Calves, Cows or Bulls from the main menu bar.
Calves
Cow Sense will display an Export File Name window (see Figure 84). It will give a default name of TREATCAF .TXT . You can overwrite that file
name if you wish. After you’ve established a file name, click the OK button
and Cow Sense will begin exporting calf treatment data to the
c:\cowsense\export directory. If you already have a text file with the same
name as the file you’re exporting, Cow Sense will give you a warning and
allow you to either replace the existing file, append new records to the
existing file, or change the file name. When Cow Sense is finished exporting,
it will display an Export Finished window telling you the number of records
it exported, the name of the export file and where to find it.
Cows
Cow Sense will display an Export File Name window (see Figure 84). It will give a default name of TREATCOW .TXT . You can overwrite that file
name if you wish. After you’ve established a file name, click the OK button
and Cow Sense will begin exporting cow treatment data to the
c:\cowsense\export directory. If you already have a text file with the same
name as the file you’re exporting, Cow Sense will give you a warning and
allow you to either replace the existing file, append new records to the
existing file, or change the file name. When Cow Sense is finished exporting,
it will display an Export Finished window telling you the number of records
it exported, the name of the export file and where to find it.
Bulls
Cow Sense will display an Export File Name window (see Figure 84). It will give a default name of TREATBUL.TXT . You can overwrite that file
name if you wish. After you’ve established a file name, click the OK button
and Cow Sense will begin exporting bull treatment data to the
c:\cowsense\export directory. If you already have a text file with the same
name as the file you’re exporting, Cow Sense will give you a warning and
allow you to either replace the existing file, append new records to the
existing file, or change the file name. When Cow Sense is finished exporting,
it will display an Export Finished window telling you the number of records
it exported, the name of the export file and where to find it.
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IMPORT
You can import data into Cow Sense to add information such as
existing cow, bull or calf records from a number of sources including database files, spreadsheet files and electronic scales. This is a powerful tool to
link ranches to other chains in the beef production industry. You can import
any tab-delimited text file that contains matchable fields, which allows you
to import not only weight values, but also feedlot and carcass data as well as
EPD updates and electronic IDs (EIDs) that are cross-referenced to an
existing animal ID in Cow Sense.
TM

TIP: A S A PRECAUTION YOU
SHOULD MANUALLY RECORD
WEIGHTS FORM YOUR
ELECTRONIC SCALES, EVEN IF
YOU INTEND TO ELECTRONICALLY IMPORT THE WEIGHT
DATA . THE HARD COPY CAN

Importing Weight Data Directly Using Cow COMM
You have two options for downloading electronic weight data into
Cow Sense: directly using Midwest MicroSystems’s Cow COMM, and
indirectly.

BE GOOD INSURANCE AGAINST

Cow Sense Cow COMM product facilitates direct import from
certain scale models and makes into Cow Sense by linking the scale head to
your Cow Sense computer. You can find additional information on how Cow
COMM works in the Cow COMM Users Guide (an Adobe Acrobat version
of this document is available at c:/cowsense/cowcomm.pdf). You can launch
the Trial Edition of Cow COMM from Windows by clicking the Start button
and selecting Programs > Cow Sense > Cow COMM.

INVALID

Importing Weight Data Indirectly
To import weight data indirectly into Cow Sense, follow the instructions that came with your scale to save the weight data to a file on your hard
disk. You may have to copy the data from a floppy drive or use a computer
linking utility to get the data on to the same computer that houses your Cow
Sense program. Cow Sense will generally automatically identify import
settings, if the data file from the scale is delimited. If your scale gives you a
choice of saving data as delimited or limited, chose delimited. If your file is
not delimited, Cow Sense may ask you to enter data manually after verifying
IDs. Save all files with a .txt extension to make data import easier.
It is a good idea to store your data files in the c:\cowsense directory
to make data retrieval easier. You may also want to make a “weight” folder or
an “import” folder to store weight data files from your scale. Refer to your
Windows documentation if you need help learning how to create folders or
directories.
Always back up herd files prior to importing.

LOST DATA AND IT GIVES YOU
ADDITIONAL INFORMATION
THAT WILL HELP YOU MATCH
UP RECORDS WHEN YOU HAVE

IDS IN THE SCALE

FILE.

NOTE: COW
TM
COMM IS

A

COMMUNICATIONS COMPO NENT THAT ALSO LETS YOU
USE YOUR COW

SENSE

DATABASE AT THE CHUTE TO
PROVIDE INSTANT ACCESS TO
ALL RECORDED INFORMATION
ON ANIMAL RECORD . COW

COMM

INTERFACES WITH

ELECTRONIC SCALES AS WELL
AS ELECTRONIC

ID SCANNERS

AND ELECTRONIC HIP HEIGHT
MEASURING DEVICES
THROUGH YOUR COMPUTER’S
COMMUNICATIONS PORT. IF
YOU HAVE ADDITIONAL
QUESTIONS ON HOW YOU CAN

COW COMM CALL
(800) 584-0040.
USE
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Cow Weights
To import
cow weights, select
Utilities > Transfer
Data > Import >
Cow Weights from
the main menu bar.

FIGURES 8-5 AND 8-6.
THE SELECT FILE FOR
IMPORTING COW W EIGHTS
WINDOW AND THE IMPORT
SCALE COW W EIGHTS
WINDOW .

TIP: COW SENSE USES
ANIMAL IDS AS THE LINK
FIELD BETWEEN COW SENSE
DATA AND ELECTRONIC SCALE
DATA .

TO

AVOID CONFLICTS

BE SURE THAT THE

IDS IN

THE SCALE CORRESPOND TO

IDS IN COW SENSE .
FOR EXAMPLE, IF YOU ENTER
A CALF ID INTO THE SCALE
AS 123, AND THE CALF ID IN
COW SENSE IS 123J, COW
SENSE WILL NOT IMPORT THE
THE

WEIGHT DATA ON THAT
ANIMAL ;

ID 123 WILL

APPEAR IN AN ERROR LOG .

Cow Sense will
display a Select File
for Importing Cow
Weights window
(see Figure 8-5).
The window
includes instructions for you to click on the file you want to select for
importing weights. The Directories box will default to c:\cowsense folder. If
your weight data file is there (listed in the File Name box), click on the name
of the file. If not, use standard Windows directory-tree protocol for finding
the folder that contains your data file.
Once you click on a file (for example, Cows00.txt), Cow Sense will
tell you if the file is valid or invalid in blue letters. If the file is valid, it will
list the number of records in blue letters just below the VALID Text File box.
Click the Import button to proceed.
Cow Sense will display an Import Scale Cow Weights window (see
Figure 8-6). It will list the file you’re trying to import in the Selected File
box and give the number of records in the Record Count box. In the Field
Order in File box, Cow Sense will attempt to place the order of the data. It
will, as a default, assume that the animal IDs are in the first data column and
that the weights are in the second column. If your data is in a different order,
you can override the column numbers in the boxes. If you have one date for
all the weights in the data set, enter the weight date in the Default Weight
Date box (Cow Sense will automatically put the current date in the box).
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Click on a row of data in the data box at the bottom of the window to
establish a data pattern. Cow Sense will display the order of the data based
on the sample you clicked and the order you established in the Field Order in
File box in the Sample Data box. If everything looks correct, click the
Validate Records button and Cow Sense will display a box showing any
validation errors. Click the OK button and Cow Sense will display any errors
in the data box at the bottom of the Import Scale Cow Weights window. If
any records are invalid, you can scroll through the list to observe the invalid
records (for example, if a record has a missing weight). If a record is invalid,
Cow Sense will not import it. Therefore, if you have 200 weight records, but
Cow Sense finds that 15 are invalid (have missing weights or ID irregularities), Cow Sense will only import the 185 records that are sound.
When you’re satisfied that the data is accurate and as complete as
possible, click the Import Weights button. Cow Sense will display a Proceed
with Import window, making sure it is all right to import all valid records.
Click the Yes button to continue or the No button to return to the Import
Scale Cow Weights window.
When the weight import is complete, Cow Sense will display a Data
Transfer Completed window listing the number of records it imported into
the current herd.
Weaning Weights
To import weaning weights, select Utilities > Transfer Data >
Import > Weaning Weights from main menu bar. Cow Sense will display a
Select File for Importing Weaning Weights window (see Figure 8-7).

FIGURES 8-7.
THE SELECT FILE FOR
IMPORTING W EANING
W EIGHTS WINDOW .
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The window will provide instructions for you to click on the file you
want to select for importing weights. The Directories box will default to
c:\cowsense folder. If your weight data file is there (listed in the File Name
box), click on the name of the file. If not, use standard Windows methods for
finding the folder that contains your data file.
Once you click on a file (for example, Wean00.txt), Cow Sense will
tell you if the file is valid or invalid in blue letters. If the file is valid, it will
list the number of records in blue letters just below the VALID Text File box.
Click the Import button to proceed.
FIGURES 8-8.
THE IMPORT SCALE
W EANING W EIGHTS
WINDOW .

Cow Sense
will display an
Import Scale Weaning Weights window
(see Figure 8-8). It
will list the file
you’re trying to
import in the Selected File box and
give the number of
records in the
Record Count box.
In the Field Order in
File box, Cow Sense will attempt to place the order of the data. It will, as a
default, assume that the animal IDs are in the first data column and that the
weights are in the second column. If your data is in a different order, you can
override the column numbers in the boxes. If you have one date for all the
weights in the data set, enter the weight date in the Default Weight Date box
(Cow Sense will automatically put the current date in the box).
Click on a row of data in the data box at the bottom of the window to
establish a data pattern. Cow Sense will display the order of the data based
on the sample you clicked and the order you established in the Field Order in
File box in the Sample Data box. If everything looks correct, click the
Validate Records button and Cow Sense will display a box showing any
validation errors. Click the OK button and Cow Sense will display any errors
in the data box at the bottom of the Import Scale Weaning Weights window.
If any records are invalid, you can scroll through the list to observe the
invalid records (for example, if a record has a missing weight). If a record is
invalid, Cow Sense will not import it. Therefore, if you have 200 weight
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records, but Cow Sense finds that 15 are invalid (have missing weights or ID
irregularities), Cow Sense will only import the 185 records that are sound.
When you’re satisfied that the data is accurate and as complete as
possible, click the Import Weights button. Cow Sense will display a Proceed
with Import window, making sure it is all right to import all valid records.
Click the Yes button to continue or the No button to return to the Import
Scale Weaning Weights window..
When the weight import is complete, Cow Sense will display a Data
Transfer Completed window listing the number of records it imported into
the current herd.
Yearling Weights
To import yearling weights, select Utilities > Transfer Data >
Import > Yearling Weights from the main menu bar. Cow Sense will display
a Select File for Importing Yearling Weights window (see Figure 8-9).
The box will
give instructions for
you to click on the
file you want to
select for importing
weights. The Directories box will
default to
c:\cowsense folder.
If your weight data
file is there (listed in

FIGURES 8-9 AND 8-10.
THE SELECT FILE FOR
IMPORTING YEARLING
W EIGHTS WINDOW AND THE
IMPORT SCALE YEARLING
W EIGHTS WINDOW .

the File Name box),
click on the name of
the file. If not, use
standard Windows
methods for finding
the folder that
contains your data
file.
Once you
click on a file (for
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example, Yrlg00.txt), Cow Sense will tell you if the file is valid or invalid in
blue letters. If the file is valid, it will list the number of records in blue letters
just below the VALID Text File box. Click the Import button to proceed.
Cow Sense will display an Import Scale Yearling Weights window
(see Figure 8-10). It will list the file you’re trying to import in the Selected
File box and give the number of records in the Record Count box. In the
Field Order in File box, Cow Sense will attempt to place the order of the
data. It will, as a default, assume that the animal IDs are in the first data
column and that the weights are in the second column. If your data is in a
different order, you can override the column numbers in the boxes. If you
have one date for all the weights in the data set, enter the weight date in the
Default Weight Date box (Cow Sense will automatically put the current date
in the box).
Click on a row of data in the data box at the bottom of the window to
establish a data pattern. Cow Sense will display the order of the data based
on the sample you clicked and the order you established in the Field Order in
File box in the Sample Data box. If everything looks correct, click the
Validate Records button and Cow Sense will display a box showing any
validation errors. Click the OK button and Cow Sense will display any errors
in the data box at the bottom of the Import Scale Yearling Weights window.
If any records are invalid, you can scroll through the list to observe the
invalid records (for example, if a record has a missing weight). If a record is
invalid, Cow Sense will not import it. Therefore, if you have 200 weight
records, but Cow Sense finds that 15 are invalid (have missing weights or ID
irregularities), Cow Sense will only import the 185 records that are sound.
When you’re satisfied that the data is accurate and as complete as
possible, click the Import Weights button. Cow Sense will display a Proceed
with Import window, making sure it is all right to import all valid records.
Click the Yes button to continue or the No button to return to the Import
Scale Yearling Weights window..
TIP: IF YOU

RECEIVE DATA

FROM AN OUTSIDE SOURCE ,
DO NOT LOAD DATA ON TO
YOUR HARD DRIVE WITHOUT
A VIRUS SCANNING SYSTEM

(SUCH AS NORTON
A NTI VIRUS OR M CAFFEE
VIRUS SCAN).

Cow Sense will display a Data Transfer Completed window after the
transfer is finished, listing the number of records it imported.

IMPORT TOOL
In addition to importing weight data, you can import a variety of offranch information, including feedlot, carcass and EPD data, that relates to
your herd records. The Cow Sense Import Tool window to guide you through
the process. You can also use the Import Tool to import weight data.
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Back up your Cow Sense data prior to using this tool. Do not
accept data from an outside source without a virus scanning device.
Before you open up the Import tool, be sure to save your data in a
tab-delimited format. Generally you will do this by selecting the File > Save
As or the File > Export option from the database or spreadsheet where the
data originates. If you are receiving the file from an outside source, be sure
the source personnel save it as a tab-delimited text file (it should have a .txt
extension following the file name).
To access the Import Tool, select Utilities > Transfer Data >
Import > Import Tool from the main menu bar. Cow Sense will display an
Import Tool V.x.x window (see Figure 8-11).
When you
import records, Cow
Sense targets a
specific production
cycle. You can
choose the production cycle by clicking the Hot button in
the Select Production
Cycle box. If the file
you’re importing has
records for more
than one production
cycle, first separate
the records in a
spreadsheet or
database into separate production cycles. Then import records for each
production cycle.
Also, be sure you have the correct Herd file open. If you have the
wrong herd file open, you can select a different herd by clicking the Change
Herd button in the Import Tool window; Cow Sense will display the familiar
Locate Herd file window, which is the same window that appears when you
select File > Open Herd from the main menu bar (see Chapter 3).
After you are sure you have the correct herd and production cycle
established for importing data, select the table to which you want to import
data—Calves, Cows or Bulls—by clicking the appropriate radio button in the

FIGURE 8-11.
THE IMPORT TOOL WINDOW .
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Table box. Also, make sure the fields to which you want to import data are
available. Do this by using the Maintenance > Administration > Customize Data Field command (see Chapter 7).
FIGURE 8-12.
THE LOCATE IMPORT FILE
WINDOW .

FIGURE 8-13.
THE FREE FORM TEXT DATA
BOX IN THE IMPORT TOOL
WINDOW .

FIGURE 8-14.
THE LINKING FIELDS OF THE
SOURCE AND TARGET FILES IN
THE IMPORT TOOL WINDOW .

Next, select the file you
wish to import by clicking on the
Locate Import File Button. Cow
Sense will display a Locate File
Import box (see Figure 8-12). The
default directory in this box is
c:\cowsense. Use standard Windows directory tree protocol to
find the import file. When you
have located the file you want to import, select it and click the OK button to
continue.
Cow Sense will show Sample Data in the free-form text box at the
bottom of the Import Tool window (see Figure 8-13). Most tab-delimited
data files have a header row, which contains field names. Information in this
row is displayed
in the Source
Field column
(the far left
column above
the free-form
text box). If
your data file
does not have a header row (if data starts in the first row) then data will
appear in the Source Field column. If you do have field names in the first
row, be sure the “Yes” radio button is selected for the Header Row. If your
first row is actual data, select the “No” Header Row radio button. Cow Sense
will “strip” the first row if the Header
Row radio button is set on “Yes”.
Next, select the Linking Field (see
Figure 8-14). The Linking Field is the
anchor field between the two data sets. It
is the field by which records are appended
into an existing Cow Sense table. You link
only to one field, so use the most reliable
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field available for linking. Generally that will be an animal ID field. Highlight
the linking field of choice in the Source Field column, and then highlight the
linking field of choice in the Import Field column. Click the >>> button to link
the two databases by that common field (the field names don’t have to be the
same, but the data that you want to transfer should be in the same format).
Once the source and target fields are associated, Cow Sense will display the
source file name (or data value if you do not have headers) in the ImportField
column of the target grid. This process is called “mapping”.
After you establish the Linking field, select the source fields you want
to transfer, one at a time. To do this, first highlight a source field, and then
highlight the corresponding target field; click the >>> button. For instance, if
you have a source field called Milk EPD, select the corresponding Cow
Sense EPD field (EPD Milk in the Sample herd). Once the source and target
fields are associated, Cow Sense will display the
source file name (or data value if you do not have
headers) in the ImportField column of the target
grid. Once again, if you do not have headings in
your source field, highlight the appropriate data
value that associates with the target field
and be sure the Header Row “No” radio
button is selected.
Once you have mapped all the
data fields to import, click the Save Spec
button to save the import specifications
(see Figure 8-15). Then next time you
want to run the same import routine, you
do not have to match the source and
target fields before import; you only need
to use the Recall Spec button (see Figure 8-16) to recall an import specification routine before you click the Import Data button.
After you have saved the import specification, click the Import Data
button. Cow Sense will display an Import Complete window telling you how
many records it successfully appended.

PREMIUM INTERFACE COMPONENT
The Premium Interface Component (PIC) is an optional Cow Sense
utility that you purchase separately. This utility allows you to exchange data
electronically with breed associations and other organizations using preset
import and export routines.
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TIP: IF

YOU ARE IMPORTING

DATA SUCH AS WEIGHTS OR
PELVIC MEASUREMENTS THAT
WILL REQUIRE A DATE FOR
ADJUSTMENTS, MAKE SURE A
MEASUREMENT DATE EXISTS
IN THE DATA YOU ARE
IMPORTING. IF NOT, CREATE A

M EASUREMENT DATE FIELD
IN THE SOURCE FILE PRIOR TO
IMPORTING THE DATA INTO

COW SENSE .

FIGURE 8-15 AND 8-16.
THE SPECIFICATIONS NAME
WINDOW AND THE RECALL
SPECIFICATIONS WINDOW .

TIP: IF YOU

IMPORT DATA

SEVERAL TIMES IN THE SAME
HERD , YOU DO NOT HAVE TO
SET UP THE IMPORT ROUTINE
EVERY TIME IF YOU HAVE
SAVED THE ROUTINE IN THE

SAVE SPECIFICATIONS
WINDOW . JUST CLICK THE
RECALL SPEC BUTTON TO
RETRIEVE A LIST OF SAVED
IMPORT ROUTINES.

SELECT

THE ROUTINE YOU WANT TO
USE FOR IMPORTING DATA ;
REVIEW THE IMPORT SPECIFICATIONS FOR ANY CHANGES,
AND CLICK THE

OK BUTTON .
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FIGURES 8-17 AND 8-18.
THE COW SENSE PREMIUM
INTERFACE COMPONENT
ACTIVATION BOX AND COW
SENSE PIC SHELL .
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The Premium Interface component
comes with its own documentation. You can
open the component without an activation key,
but you must have a registered activation key in
order to use the program. To find out more
information about this
utility select Utilities >
Transfer Data >
Premium Interface Component
from the main
menu bar. Cow Sense
will display the
PIC Activation window
(see Figure 817). Click the Continue
button,
and
Cow Sense will launch
the Cow Sense
Premium Interface
Component shell (see Figure 8-18). Select Help > More > Breed Associations and Production Systems from the main menu bar.
For the latest information about the PIC, call the Midwest MicroSystems sales desk at 800-584-0050.

COW MOOVER
FIGURE 8-19.
THE COW M OOVER SHELL .

Cow Moover is an independent
utility program within Cow Sense that
lets you move whole-herd cow and bull
tables into other herd data sets. Essentially you append one herd’s cow and bull
tables into another when you use Cow
Moover. You also have the option of
transferring a parent’s current calf and
past progeny records along with his or her
records when you use this utility.
Because Cow Moover is an independent program accessible through
Cow Sense, the documentation for it is in a separate publication. You can
access—view and print—this documentation by using Adobe Acrobat reader.
For more information on installing Adobe Acrobat Reader, see Chapter 9.

The Window and Help Menus

Chapter 9: The Window & Help Menus
WINDOW
In the Cow Sense Windows environment, you may have several
windows open at once. For instance, you may have an Enter Cows data entry
window and an Enter Bulls data entry window open at the same time. Or you
may have some report windows open for reference as you enter animal data.
The Window menu contains a listing of all open windows in Cow Sense. The
active window on your desktop will have a check mark (?) by it in the
Windows menu. You can highlight the window in which you want to work by
selecting it in the Window menu.
The Window menu also contains options for closing all open windows and for cascading windows.

CLOSE ALL W INDOWS
The Close All Windows command will shut all the open windows in
your Cow Sense desktop shell at the same time. To close all windows and be
left with a blank Cow Sense shell, select Window > Close All Windows
from the main menu bar. You can also press the
icon to close all open
windows on your Cow Sense desktop shell.

CASCADE W INDOWS
The Cascade Windows option cascades all the open windows in the
Cow Sense shell. To cascade windows, select Window > Cascade Windows
from the main menu bar. You can also press the
icon to cascade all open
windows on your Cow Sense desktop shell.

DATA ENTRY MODE
Data Entry Mode changes the behavior of the Hot button in the ID
field on bull and cow list reports. Normally, this Hot button launches the
Individual Summary for the animal you have selected. In Data Entry Mode,
the Hot button launches a data entry form for the animal instead (see Figure
9-1). This feature is very useful for editing animal records when working
from a list, allowing you to fix errors you see in on-screen reports without
having to open the Enter Data window and find the animal record associated
with the error.
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FIGURE 9-1.
A N ENTER INDIVIDUAL
A NIMAL WINDOW ACCESSED
FROM AN A NIMAL LISTING
WINDOW .

To use Data Entry Mode, open any cow or bull report—excluding the
Individual Listing reports. If you see an error in a record of the on-screen
report, go to the main menu bar and select Window > Data Entry Mode . A
check mark will appear by the words. Then simply click the Hot button on the
animal’s ID field, and Cow Sense will automatically pull up an Edit Individual
[Animal #] window. When you’ve finished editing that animal’s record, click
the Close button and you will return to the open report window.
To return to the normal reporting mode, select Window > Data
Entry Mode again from the main menu bar; this will remove the check mark
and trigger the Hot button in the ID field on cow and bull list reports to once
again access an animals Individual Summary report window.

HELP
COW SENSE HELP
Cow Sense provides full documentation on-line when you select
Help > Cow Sense Help from the main menu bar. Cow Sense will display
the Cow Sense Help screen, starting at the Cow Sense Help Contents. This
screen is similar to other Windows Help screens in other programs. You can
also press the
icon to access the Cow Sense Help screen.

The Window and Help Menus

Contents Button
The underlined sans serif text in the Cow Sense Help Contents
screen is in hypertext, so when you click on any hyperlinked text, Cow Sense
Help will take you to a page regarding that topic. You can jump to more
detailed information about a topic with each click on the hyperlink text. Use
the Back button at the top of the screen if you want to return to a previous
help page. If an explanation doesn’t fit on one page, use the scroll bar on the
right side of the screen to page down.
Search Button
When you click on the Search button, Cow Sense will display a Help
Topics box. You can search for information two ways: using Index and using
Find.
Index Tab
In the Index option, you can type in a word for which you want help
in the top box or you can scroll through an index of Cow Sense words in the
lower box. Once you’ve selected a word for which you want more information, click the Display button at the bottom of the box. Use this option if you
only want to look up one word.
Find Tab
The Find option builds a database of every word in the Cow Sense
help file and lets you search for information based on more than one word.
The first time you use this option, you’ll have to build the database
of words using the Find Setup Wizard.
After you’ve built the database, you can select the word or words for
which you want more information either by typing it/them in the first box, or
by selecting it/them from the second box (if you want to select more than one
word from the box, hold down the CTRL key while you click on the words).
Once you’ve selected a word or words, the program will display in the third
box all the areas of the help file where those words occur. Click the general
area for which you’re searching for information and then click the Display
button.
Back and << >> Buttons
The Back button and the << button perform the same role. They take
you to the previous page of the Cow Sense on-line help document. The >>
button (forward button) takes you to the next page of the Cow Sense on-line
help document.
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Print Button
Click the Print button to send a Help page to your printer. If you have
more than one printer option, select the desired printer from the Name list.
When you have the right printer and the proper settings (established by
clicking the Properties button), click the OK button to proceed.
Glossary Button
Click the Glossary button to access a glossary of common Cow
Sense terms. This glossary is also available in this User’s Guide.

USER’S GUIDE
Cow Sense comes with a complete User’s Guide in an Adobe
Acrobat Reader format (called guide.pdf). This file format allows you to both
view on-line and print the Cow Sense User’s Guide (either sections or the
whole document).
If you already have Adobe Acrobat Reader version 2.1 installed on
your hard drive at c:\acroread, you can open the file by clicking User’s Guide
from the Help drop-down menu. If you don’t have Adobe Acrobat Reader
installed at c:\acroread, first install it using the following instructions and then
you can read and print the User’s Guide. If you have Adobe Acrobat Reader
installed in another directory and you don’t want to install a second version in
c:\acroread, you can open the files by first opening Adobe Acrobat Reader
and then using the File > Open command, or by using Windows Explorer.
Installing Acrobat Reader During Initial Cow Sense Installation
Be sure Cow Sense is closed before you begin installation.

FIGURE 9-2.
THE INSTALL A DOBE
A CROBAT READER?
WINDOW .

Adobe Acrobat Reader comes on the Cow Sense installation disks.
When you start the Cow Sense installation CD, select “Install Cow Sense”
from the list of options. You will proceed through five installation windows,
and then Insallshield will display an Install Adobe Acrobat Reader? window
(see Figure 9-2). It will ask if you
would like to install Adobe Acrobat
Reader. Click the Yes button to install.
Installing Acrobat Reader After
Cow Sense Installation
To install Adobe Acrobat
Reader in Windows 95 or higher, from
the Start button, choose Run and type
c:\cowsense\acroread\acroread.exe

The Window and Help Menus

(this command assumes the default directory for Cow Sense) to launch the
Adobe Acrobat Reader installation utility. Or using Windows Explorer (and
assuming you installed Cow Sense in the c:\cowsense directory), click open
the c:\drive (
) and then click open the Cow Sense folder
(
). Double click the Acroread folder (
), and
then double click on Acroread.exe. This will launch the Adobe Acrobat
Reader installation utility.
Follow the instructions on your screen. Installation requires approximately 3 MB of free hard disk space.

SPA GUIDELINES
Cow Sense has adopted and incorporated Standardized Performance
Analysis (SPA) guidelines for reproduction and production, and has been
certified by the NCBA Integrated Resources Management Subcommittee.
Cow Sense is designed so that SPA production computations can be carried
out with minimal additional data entry.
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NOTE: UNLESS YOU HAVE
A DOBE A CROBAT READER
INSTALLED AT C:\ ACROREAD ,
YOU MAY NOT BE ABLE TO

USER’S
GUIDE AND OTHER COW
SENSE PDF FILES FROM COW
SENSE . IF YOU HAVE A DOBE
A CROBAT READER 2.1 OR
DIRECTLY OPEN THE

HIGHER INSTALLED IN
ANOTHER DIRECTORY , YOU
CAN USE THE FILE

> OPEN
A CROBAT
READER TO OPEN THE COW
SENSE PDF FILES (ASSUMING
COMMAND IN

THEY ARE IN THE DEFAULT
DIRECTORY THAT WOULD BE
C:\ COWSENSE ). OR YOU CAN
USE

Cow Sense comes with an Adobe Acrobat document that explains
some of the common SPA terms and concepts, and how to apply specific
SPA concepts within Cow Sense. It guides you in data entry so that reports
accurately reflect SPA guidelines. To read on-line and / or print these guidelines, you must have Adobe Acrobat Reader installed. Please refer to the
previous section on installing Adobe Acrobat Reader.

COW SENSE SUPPORT
The Cow Sense Support option in the Help menu is designed to allow
you to communicate electronically with Cow Sense support personnel at
Midwest MicroSystems. You have three options in this menu: You can send
your Cow Sense herd database file to a support representative; you can
receive your Cow Sense herd file from a support provider; you can update
your Cow Sense program directly from Midwest MicroSystems internet
customer service center.
You must have an internet connection to use these options.

SEND HERD FILE
Sometimes Cow Sense support representatives run into support
questions that are best handled when they can see your actual herd file. The
Send Herd File command allows you to upload your herd file database to

W INDOWS EXPLORER TO

OPEN THE FILES.
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Midwest MicroSystems by way of the internet so that a support representative can correctly diagnose your problem and provide a solution. You must
have an active dial-up connection in order to use this support tool.
Generally you will have been in contact with a support representative
by telephone or e-mail prior to transmitting your herd file over the internet.

FIGURE 9-3 TO 9-5.
THE SEND HERD VIA FTP
WINDOW , THE CONNECT
WINDOW AND THE

M ICRO FTP WINDOW .

To send a herd file to Midwest MicroSystems, first be sure that the
herd file you want to send is the current herd you have open (the file you
selected with the File > Open Herd command if you have more than one
herd file established in Cow Sense). Then select Help > Cow Sense Support > Send Herd File from the main menu bar. Cow Sense will display a
Send Herd via FTP window (see Figure 9-3). Click the Yes button to continue. Cow Sense will display a Connect window (see Figure 9-4). Click the
Launch MicroFTP button to continue. When you click the Launch MicroFTP
button, Cow Sense will create a special herd backup file with a .trx extension
(for example,
“mycows.trx”). Cow
Sense will then display
a MicroFTP window
(see Figure 9-5). Click
on the Hot button in the
Connection field to select a connection device
(for example, a dial-up connection from a local
internet service provider (ISP)). Once you have

the appropriate
connection device,
click the Connect
button to launch
MicroFTP and send
your herd file to
Midwest MicroSystems (see Figure 9-6).
MicroFTP will compress the file and give it a .zip extension. It will also
establish a connection with the Midwest MicroSystems customer service FTP

The Window and Help Menus

199

site. When the file transfer is
complete, Cow Sense will
display a window indicating
that the transfer is complete
(see Figure 9-7). Click the
Exit button in the Connect
window when you’ve
finished uploading your file to
Midwest MicroSystems.
Cow Sense will display a
window indicating that the
file transfer was successful.
Click the OK button. Then, send
an e-mail message to Midwest
MicroSystems customer support at
support@midwestmicro.com to
alert support representatives that
you sent your file and to notify
them of the problems you need them to address.

RETRIEVE HERD FILE
After a Midwest MicroSystems support representative has retrieved
and reviewed the herd file that you uploaded for support, has diagnosed a
problem, and provided a solution, he will notify you that you can download the
herd file back into Cow Sense using the Retrieve Herd File command. If the
support representative furnishes a solution without altering your database file,
you will not need to download the file back into your system. If the support
representative fixes a problem directly inside your file, however, you must
download it back into your own Cow Sense system in order for the fix to take
affect.
Before you begin downloading a repaired Cow Sense file from
Midwest MicroSystems support, be sure you have made a backup of your
current herd file.
To download a file from Midwest MicroSystems support, select Help
> Cow Sense Support > Retrieve Herd File from the main menu bar. A
Retrieve Herd File via FTP window will appear (see Figure 9-9). If you are
sure you have a backup of (all) your herd file(s), click the Yes button to
continue. Cow Sense will display a Connect window (see Figure 9-10). Click

FIGURE 9-6.
THE M ICRO FTP CON NECTED WINDOW DISPLAYING
THE DOWNLOAD TO THE

M ICRO FTP SITE FROM A
RANCH -BASED COMPUTER.

FIGURES 9-7 AND 9-8.
THE M ICRO FTP SESSION
COMPLETE WINDOW AND
COW SENSE FILE TRANSFER
SUCCESSFUL WINDOW .
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the Launch MicroFTP
button to continue. Cow
Sense will then display a
MicroFTP window (see
Figure 9-11). Click on the

FIGURES 9-9 TO 9-11.
THE RETRIEVE HERD VIA
FTP WINDOW , THE
CONNECT WINDOW AND THE
M ICRO FTP WINDOW .

Hot button in the
Connection field to
select a connection
device (for example, a dial-up connection from a local internet service
provider (ISP)). Once you have the appropriate connection device, click the
Connect button to launch MicroFTP and retrieve your herd file from Midwest
MicroSystems (see Figure 9-12). MicroFTP will establish a connection with
the Midwest MicroSystems customer service FTP site. When the file transfer
is complete, Cow Sense will display a window indicating that the session is
complete. (see Figure 9-13). Click the OK button. Cow Sense will redisplay
the Connect window. Click the Exit button, and Cow Sense will display a

FIGURE 9-12.
THE M ICRO FTP CON NECTED WINDOW DISPLAYING
THE FILE UPLOAD FROM THE

M ICRO FTP SITE TO A
RANCH -BASED COMPUTER.
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window explaining that upon clicking the OK button, the program will decompress the downloaded file and restore the herd file directly into your c:/
cowsense/herds folder (see Figure 9-14). After you click the OK button, Cow
Sense will display a warning box to be sure you
want to overwrite the current herd file (Figure 915). If you have not backed up your herd file
prior to beginning the
Retrieve Herd File
command, you should
select the No button. If

all your data is backed up,
click the Yes button to continue. Once Cow Sense
restores your herd file, it will
display a Restore Complete window (Figure 9-16).
Click the OK button to exit the restore command.

UPDATE COW SENSE
While as a registered Cow Sense user, Midwest MicroSystems will
notify you regarding future upgrades as they become available, you can
download periodic maintenance updates and intermediate version releases
any time. Midwest MicroSystems releases these updates frequently, so it’s a
good idea to run the Update Cow Sense utility routinely. In an effort to make
updating hassle-free, you can use the MicroFTP tool to retrieve updates as
often as necessary.
To receive an update easily, select Help > Cow Sense Support >
Update Cow Sense from the main menu bar. Cow Sense will display a
Receive Update via FTP window (see Figure 9-17). When you click the Yes
button to continue, Cow Sense will display a Connect window (see Figure 918). Click the Launch MicroFTP button to continue. Cow Sense will then
display a MicroFTP window (see Figure 9-19). Click on the Hot button in the
Connection field to select a connection device (for example, a dial-up connection from a local internet service provider (ISP)). Once you have the appropriate connection device, click the Connect button to launch MicroFTP and
update Cow Sense from Midwest MicroSystems. MicroFTP will establish a
connection with the Midwest MicroSystems customer service FTP site. If an

201

FIGURES 9-13 TO 9-16.
THE FILE TRANSFER
SUCCESSFUL WINDOW , THE
PROCEED WITH RESTORE
WINDOW , THE REPLACE
HERD FILE WINDOW , AND
THE RESTORE COMPLETE
WINDOW.
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update is available, Cow
Sense will retrieve it into
its system. When the
update transfer is complete, Cow Sense will
display a window indicat-

FIGURES 9-17 TO 9-19.
THE RECEIVE UPDATE VIA
FTP WINDOW , THE
CONNECT WINDOW , THE
M ICRO FTP SESSION
WINDOW , AND THE
M ICRO FTP SESSION
COMPLETE WINDOW .

FIGURE 9-20.
.

ing that the
update was
successful, or it
will tell you that
you have the most current
version and that Midwest
MicroSystems has not
released an update since
your last update (see Figure 9-20).

ABOUT COW SENSE
When you select this option from the Help menu, Cow Sense will
display a window with information about your current version of Cow Sense,
including the version number you’re using. You can find both your registration
number and serial number in this window as well as avenues for obtaining
support (see Figure 9-21).

FIGURE 9-21.
THE A BOUT COW SENSE
WINDOW .
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Active/Inactive
You have three choices for the status of a cow or bull in the Cow
Sense cow and bull tables. An “active” cow or bull is one that Cow Sense
considers a potential breeder. An inactive cow or bull is one that you intend
to or have removed from the herd; you designate their status as “going”
(cows only) or “gone” in the status field of cow and bull tables. Cow Sense
will change the “going” record in the cow table to a “gone” record after you
run a new cycle. You can show or suppress “gone” records with a query.
Adjusted Weight
To be comparable, weights must be adjusted for factors known to
influence them. Adjusted Weight allows you to compare weights because it
takes into account factors that influence actual birth, weaning and yearling
weights in a predictable way: cow age, calf age and calf sex. Adjusted
Weight thus allows you to make comparisons among your calves and use the
calf weights to measure the performance of their parents.
By default, Cow Sense uses the Beef Improvement Federation
standards for adjusted weights. You can choose specific breed standards in
Purebred mode or create custom standards in the Maintenance > Administration > Setup option.
Backup
A backup is a copy of your herd file that you make for protection
against any mishap that damages your active file. The copy might be on your
hard disk, but it should also be on removable media for greater security.
Backups stored on your computer's hard disk are placed in the
c:\cowsense\herdsbak subdirectory and given a numeric extension that
indicates the sequence in which they were made. Backups that Cow Sense
creates automatically when you do an upgrade are given an extension that
indicates the previous version of Cow Sense.
BIF
BIF stands for Beef Improvement Federation, a national organization
responsible for setting standards and guidelines for beef cattle performance
records.
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Break-even Price
Break-even price is the amount, per pound, you need to receive for
your calves in order to cover all of your costs to produce those calves. It is
important to include hidden costs, such as depreciation and open cows, and
opportunity costs, such as the value of owned pasture or feed produced, as
well as out-of-pocket expenses.
Calf History
Calf History is the ultimate outcome of a cow’s exposure to the bull.
The Calf History is specified with a code that you chose from a list of codes
you access when you click on a hot button. If a cow does not give birth, you
record the reason in the Calf History field. If a calf dies, you record the date
in the Calf History field.
Cell
A Cell is the intersection of a row and a column on a grid or table.
Cohort
A Cohort is a group of individuals that have a common statistically
characteristic (for example, a single season’s calves from first-calf heifers).
Contemporary group
This is a group of cattle of the same sex, of similar age, and that have
been handled in substantially the same way. You should account for management practices that affect performance by defining appropriate contemporary
groups.
Data
Data is a collection of information that you obtain and then enter,
store, manipulate, and analyze in Cow Sense.
Database
A Database is a special type of file that contains information organized as fields and records. Your herd data is stored as a database that is
independent of all other Cow Sense program files. Each herd is stored in a
separate database. Each database contains several data tables. Herd database
files are designated with an .HRD extension and stored in the
c:\cowsense\herds subdirectory. Cow Sense creates another reference file for
each herd with a .LDB extension, but these files are not essential to your data
and are recreated each time the herd is opened.

Glossary

Default
A Default is a value that Cow Sense supplies for you on an entry
form. Cow Sense uses defaults for repetitive or commonly-occurring values,
thereby saving you considerable time entering data, providing consistency,
and reducing errors.
Data Entry Mode
When you have Window > Data Entry Mode selected, you can
access an Edit Individual Cow or Edit Individual Bull window from the Hot
button on Cow and Bull ID fields.
Delete
When you delete a record, you permanently remove it from the
database. Cow Sense will ask you to confirm the action before proceeding.
Drop-down List
A Drop-down List is a data entry field where you pick the entry off a
predefined list. The drop-down list saves you time and prevents typographical errors. Cow Sense uses drop-down lists extensively for data entry
Edit Mode
Edit Mode occurs when you are changing information in, or appending information to a record in an Enter Data window in Cow Sense.
EPD
EPD stands for Expected Progeny Difference. EPDs indicate how an
animal will perform relative to other members of its breed. An EPD does not
tell you what the outcome of a given mating will be, but rather represents
average performance over a large number of matings. To be meaningful, you
must also know the average EPDs for the breed. For example, a bull with
+10 for weaning weight is below average if the breed as a whole is at +15.
Field
A Field is an entity that contains information. In your data entry
windows, fields are represented by the white rectangles into which you type
or fill in with drop-down selections. In report windows, fields are represented
by a column in the grid that lists your animals or by blocks of labeled numbers and text.
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Field Form
A Field Form is a report with blanks for you to record data in the
pasture or at the working chute. The field form has preprinted IDs and/or
other information that will be useful for you. Cow Sense provides field forms
for calves and for cows.
File
A file is a group or collection of related information (such as a
software program or database) that computers treat as a unit.
Find
When you click the Find button, Cow Sense displays a window in
which you enter an animal ID for Cow Sense to retrieve a record. If the ID is
on file, Cow Sense will go to that record.
Form
A form represents a screen document that you use to enter, display,
modify, or delete data. Cow Sense has two types of forms:
• entry forms, which display one record at a time, and
• listing forms, which are reports.
Format
Format is a way of describing data fields that determines how you
can enter data into the fields. Cow Sense contains text, number, and date
formats.
Herd Name (Report Title)
The Herd Name is the title you give the herd that will appear on
reports.
Index
An index determines the order in which records appear on a report.
It may use one field or several fields in combination. The term is sometimes
also used in place of "ratio," indicating the order of performance of a set of
animals.
Menu
This is a list of related items that you may pull down with your
mouse from the main menu bar at the top of the main Cow Sense shell.
MPPA
MPPA stands for Most Probable Producing Ability. This is a performance ratio that allows you to compare a cow’s historical production reliably.
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It is based on a cow’s cumulative average adjusted 205 day ratio, but it also
takes into consideration the number of calves she has had. For example, if a
cow has only had one or two calves, the MPPA is adjusted toward the mean
for your herd. This reduces the likelihood of making incorrect decisions
based on limited observations. If a cow has had many calves, the MPPA is
very close to her cumulative average adjusted 205 day ratio.
New
When you click the New button in an Enter Data window, Cow
Sense displays a new entry form so you can enter a new record.
Operator
An operator establishes a relationship between and among records in
a query (see Query). It determines what records a query returns. When
establishing queries, you use operators to tell Cow Sense how to use a field
for sorting records. Cow Sense uses both relational operators (such as
“Begins With”, “Equals”, or “Contains”) and logical operators (“And” or
“or”). When you click in an Operator rectangle, Cow Sense activates a query
Hot button, which provides a pop-up list of available operators.
Production Cycle
A Production Cycle begins when you expose a group of cows to
breeding, either by AI or by natural service. It ends when you take yearling
weights on the calves (or weaning weights, if you do not use yearling
weights). A cow that is nursing a calf and running with a bull is actually in
two different production cycles at the same time. This frame of reference
takes losses prior to calving into account when measuring your herd’s overall
performance.
Cow Sense works in conjunction with the natural production cycle(s)
of your herd. You begin each production cycle with a set of cows exposed to
breeding. Records for those cows should remain in Cow Sense for the entire
production cycle, even if you cull open or problem cows before you close the
cycle. This way your reports will accurately reflect the productivity of the
herd as a whole.
Query
Querying is a method of selecting a subset of records. You can use a
query for analysis. (For example, to look at the performance of two-year-old
cows, or to select cows with an MPPA that indicates culling.) Also you can
use the query for herd management chores, such as specifying the criteria
you want for selecting replacement heifers.
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A query consists of a field, a relational operator (see Operator), and
usually a value. Some operators, such as “Is Empty” do not require a value.
Queries may be strung together with logical operators such as “And” or “Or”
(also see Operator).
Ratio
A Ratio is a value that compares the performance of each calf to the
average of the whole herd (or the calf’s group, if you ratio by groups). Cow
Sense calculates ratios from adjusted weights. A ratio of 100 represents the
average. 110 is 10% above average, 90 is 10% below average.
Record
A Record is all the information associated with a given animal in
Cow Sense. Visualize a record as one line on a Custom Report with all fields
selected for display.
Remarks
The Remarks field stores free-form, unlimited text. Use the Remarks field to record information that you are unable to record in any other
field.
Save
When you save, you write, or store, information on disk. You work is
vulnerable to loss until you save it from your computer’s memory to disk. In
Cow Sense, your work is saved automatically each time you leave a record
by moving to a different record, or by closing the entry form. This is so
regardless of whether or not you use the Save button. If you have a problem
during data entry, you will at most lose only the most current information
you were editing in the last record.
Sort
Sort is the process of systematically ordering records—usually in
ascending or descending alphabetical or numerical order.
SPA
Standardized Performance Analysis (SPA) is a means of consistently
measuring performance in beef cow operations so that producers can make
comparison within an operation or between operations. The Guidelines for
Production and financial Performance Analysis for the Cow-Calf Producers:
Cow-Calf SPA were cooperatively developed and published in 1993 by the
Integrated Resources Management Subcommittee of the National
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Cattlemen’s Beef Association (NCBA), the United States Department of
Agriculture Extension Service, and university professionals from several
states. You can get more information about these guidelines from the NCBA
or your local extension service.
• Exposed Females. SPA is based on a production cycle that begins
when females are exposed to breeding and ends with weaning.
Reproductive performance measures are all relative to the number of
females exposed. Cow Sense accommodates this frame of reference
with the calf history codes, which account for all outcomes of
breeding. Although you are not required to enter breeding data, you
must enter a calf history code for each cow exposed to breeding. If a
cow is disposed of because of a reproductive failure (or other
problem that prevents calving), use the temporary status, “Going,” to
let Cow Sense make a record for her in the following production
cycle, so that the appropriate calf history may be entered. If a cow is
exposed to breeding but is culled bred for performance reasons, then
mark her “Gone” so that Cow Sense does not create a record for her
in the following production cycle.
• Replacements. Cow Sense detects replacements automatically by
looking for cows that did not calve in any of the previous production
cycles. Therefore, the first production cycle in Cow Sense will
consider all cows to be replacements. For the purposes of SPA, you
may run an artificial production cycle to initialize Cow Sense so that
replacements to the first true production cycle can be properly
identified. To avoid having to enter false calf data, assign each of the
records in the artificial cycle a calf history of “8.”
• Purchased Calves. SPA Guidelines exclude purchased calves (typically grafted to a foster dam who has lost her own calf) from reproductive performance measures, but not from calving distribution and
total weaning weights. In Cow Sense, create a second calf record for
the dam (as you would for twins) to accommodate the purchased
calf. To exclude the calf from SPA reproduction calculations, enter in
the calf remarks “SPA Exclude,” typed exactly that way.
• Calving Distribution Start Date. SPA Guidelines offer two methods
of identifying the start date for calving distribution. One is based on
the date the bull was turned in with mature cows (285 days after), the
other is based on the third calf born from mature cows (3 or older).
Cow Sense uses the latter method, since breeding data entry is not
required.
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•

Pregnancy Loss Percentage. SPA Guidelines offer two methods of
computing pregnancy loss percentage. Cow Sense adopts the first
method (Pregnant Females that Fail to Calve/Females Diagnosed
Pregnant).

Tab
Use the TAB key to move the cursor between fields on entry forms.
A blinking cursor indicates where your computer will receive information. If
a value already exists in a field, the value will appear highlighted. You can
also locate an insertion point in a field by clicking on it with your mouse.
Table
A table is a grouping of values representing distinct items (data) that
are related to one common entity. Each row in a table represents a collection
of data values that relate to the common entity and these values are generally
categorized into columns. Cow Sense is built on the following tables: Calf,
Cow, Bull, Breeding, Treatment.
Undo
When you click the Undo button in an Enter Data window, Cow
Sense removes the information you typed into a record before you click the
Save button.
Update
When you run Calving, Weaning and Yearling Updates, Cow Sense
makes all the calculations necessary to make useful performance measures
out of your raw weight data. Cow Sense first calculates adjusted weights and
ratios. Cow Sense then transfers calf data to the parent cow and bull, and
compiles this data with all their other calves to calculate average performance measures.
Validation
Validation is a method of comparing an entry with a set standards
and requiring that the entry meet those standards before the program will
accept the entry. Validation occurs behind the scenes, but if your entry does
not meet requirements, Cow Sense will present a “Validation Error” message
explaining why it won’t accept a value. Some validations are options. See
Maintenance > Administration > Setup.

Appendix

211

Appendices
APPENDIX 1: A COMPARISON OF KEY FEATURES BY MODE

Ease of Use
Easily navigate from one area to another
Complete searchable help section
Electronic User's Guide in PDF format
Backup, restore and repair herd file utilities
Included technical suport (time allowed differs by product.
See the Customer Support Policy)
Complete Inventory by:
Class (bull, calf, cow)
Group (location or other user-defined groups)
Subgroup (user defined; e.g., pasture)
Age, origin and purchase price
Any other distinctions, single or combined
Convert raised replacements from calf records to cow or herd
bull records
Death and disposal records for bulls, calves and cows
Calving data entry fields
Date, dam ID, sire ID, calving ease, etc...
Flexibility for year-round calving (multiple seasons)
Tabular calf data entry option for historical data entry
Reproductive Performance Measures
Average calving interval
Calving distribution
Pregnancy examination results
Pounds weaned per exposed female
Individual and group health data
Preloaded pharmacy of BQA vaccines and antibiotics
Tracks critical routes of adminisration and withdrawal
Record individual or group health treatments
Powerful reports
Print field forms for data collection
Standard reports for bulls, cows and calves
Generates a NCBA-certified SPA production report
Generates a cost of production report
Ability to edit animal records from report screens
Includes custom eport library (preloaded sample reports for
user-defined reporting)
Easily build or edit custom reports to individual specifications
Match function accomodates queries between bull, calf, cow
and treatment tables
Record Sale Data
Group
Individual
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Breeding data entry and reporting
Tracks AI and pasture exposed breeding data

EZ-75

Lite

Commercial

Purebred

?

?

?

?

Interactive semen inventory

--

?

?

?

Planned mating tool
Complete ET tracking for donors, recipients and embryos

---

---

---

?
?

?

?

?

?

Create and save custom queries and sorts

?

?

?

?

Track multiple breeds, add breeds or composites and breed
percentages
Turn off some fields irrelevant to an operation

?

?

?

?

--

--

?

?

Rename non-required fields or add new ones
Complete calf performance indicators
Calving, weaning, yearling weight data (actual, adjusted and
within herd ratios)
Individual carcass performance data

--

--

?

?

?

--

?

?

--

--

?

?

---

---

?
?

?
?

Average calving ease scores
Birth, weaning ,and yearling weight data (actual, adjusted and
within herd ratios
Calculates within herd ratios for cows (MPPA) and bulls
Extensive feedlot and carcass data (individual and averages)

?

?

?

?

?

--

?

?

?
--

---

?
?

?
?

Ultrasound data (individual and averages)

--

--

?

?

Pedigree Information
First generation pedigrees (sire and dam)

Customization flexibility for individual operations
User-defined fields for bull, calf and cow groups and
subgroups

Individual feedlot performance data
Individual ultrasound data
Lifetime progeny performance indicators for sire and dam

?

?

?

?

Multiple generation pedigrees
Track complete performance pedigrees

---

---

---

?
?

Record registration information (#, name, tattoo, blood, etc.)

--

--

--

?

Bull EPDs
Cow and calf EPDs

?
--

?
--

?
--

?
?

Global data entry and search/replace
Export data

-?

?
?

?
?

?
?

Import data

--

?

?

?

--

?

?

?

--

--

?

?

--

--

?

?

----

----

?
?
?

?
?
?

Interface with hand-held computers
Seamless data exchange with feedlots

---

---

?
?

?
?

Seamless data exchange with breed associations

--

--

--

?

?

--

?

?

Unlimited number of herds

1

?

?

?

Unlimited number of cows
Unlimited number of bulls

75
15

?
?

?
?

?
?

?

Advanced data entry or exchange functionality

Interface with Cow Moover
Move cow and bull and their historical progeny records
between herds
Interface with Sale Manager
Manage customers and complete sale data
Interface with Cow COMM
Use for chute-side data entry or retrieval from the Cow Sense
database
Compatability with electronic scale and ID readers
Seamless download directly from the scalehead
Real-time animal sorting based on your criteria
Interface with Premium Interface Component

Interface with Cow Sense Online
Instant comparisons of your herd against average of all
subscribers
Size Considerations
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APPENDIX 2: DEFINITION OF CARCASS QUALITY AND FEEDLOT
PERFORMANCE MEASURES
Column Title
Carcass Fields
Carcass Backfat
Carcass Cert Angus
Carcass Condemned
Carcass Dark Cutter
Carcass Dressing Pct
Carcass Fat Color
Carcass Final YG
Carcass Hot Weight
Carcass Kill Date
Carcass KPH
Carcass Lot Num
Carcass Marbling Num
Carcass Marbling
Carcass Maturity
Carcass Meat Color
Carcass Muscling Score
Carcass Net Return/Head
Carcass Other Defect
Carcass Other Program
Carcass Packer ID
Carcass Pct Retail
Carcass Prelim YG
Carcass Price
Carcass Quality Grade
Carcass REA
Carcass REA/CWT
Carcass Remark
Carcass Return/CWT
Carcass Return/Head
Carcass Tenderness
Feeding Fields
Feeding ADG
Feeding Adj Net Return
Feeding Conversion
Feeding Cost Feeding
Feeding Cost Gain
Feeding Cost Other
Feeding Cost Processing
Feeding Cost Treatment
Feeding Days
Feeding Feed Yard ID
Feeding Final Weight
Feeding In Date
Feeding In Value
Feeding In Weight
Feeding Lot Num
Ultrasound Fields
Ultrasound Backfat
Ultrasound Date
Ultrasound Rib Eye
Ultrasound Marbling

Definition or Use
Measurement of fat deposition between the 12 and 13th rib of the carcass at harvest
Carcass that meets the criteria of the Certified Angus Beef Program
Carcass that has been condemned
Carcass that has been identified as a dark cutter
Reported as a percentage of hot carcass weight to (shrunk) live animal weight
Color of carcass fat
Industry standard reflecting the final carcass yield grade after the chilling process
(Fat thickness, REA, HCW, KPH)
Carcass weight taken after evisceration and prior to the chilling process
Date the animals were harvested
Amount of kidney, pelvic and heart fat as a percentage of hot carcass weight
Number assigned to the group (or lot) and or the individual carcass ID number assigned at
harvest by the packing plant
Industry standard number that indicates the degree of marbling in the rib eye
Industry standard classification indicating the degree of marbling in the rib eye
Industry standard age identification system, expressed as a score
Color of carcass lean
Industry standard muscling classification at harvest expressed as a score
Net amount of money returned on a per head basis
Any additional defect of the carcass
Name(s) of other value based marketing programs for which the carcass qualifies
Name of packing plant where animal was harvested
Percentage of retail cuts from the carcass in relation to hot carcass weight
Industry standard preliminary analysis of carcass yield grade taken after chilling (Fat thickness
only)
Carcass price or value of a carcass expressed on a cwt basis
Industry standard system based on quality measures for marbling and maturity
Rib Eye Area measured at the 12th rib and reported in square inches
Ratio of rib eye area to hot carcass weight of animal expressed on a cwt basis
Any additional remarks for that animal’s carcass can be reported here
Total amount of money returned on a live cwt basis of the animal
Total amount of money returned on a individual animal
Recorded as Warner-Bratzler Shear (WBS) values
Average Daily Gain
Carcass value adjusted to a market constant price for comparison between marketing periods
Ratio reflecting the pounds of feed fed to obtain a pound of gain in live weight (dry matter basis)
Total cost of feed per head
Total of all costs incurred to add 1 lb of gain, expressed on a per lb live weight basis
Additional expenses incurred during the feeding phase, expressed on a per head basis
Processing expenses charged on a per head basis
Additional veterinarian or sick treatment expenses charged, expressed on a per head basis
Total number of days in the feedlot
Name of feed yard where animal was fed
Total individual animal weight at slaughter
Starting date of feeding period
Cost of individual animal at the beginning of the feeding period, expressed as a total $ value
Received weight of individual animals prorated back to truck pay weight
Number assigned to the group (or lot) and or an individual animal ID number assigned
at the feed yard by the feeder
Backfat detected at the 12th rib by ultrasound
Date the ultrasound was performed
Size of rib eye detected by ultrasound and reported in square inches
The percentage of intramuscular fat in the rib eye detected by ultrasound
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APPENDIX 3: DEFINITION OF CARCASS QUALITY AND FEEDLOT FIELD
CHARACTERISTICS
Column Title

Cell Format

Character
Spaces

Appearance

Appearance
after Editing

Carcass Fields
Carcass Backfat
Carcass Cert Angus
Carcass Condemned
Carcass Dark Cutter
Carcass Dressing Pct
Carcass Fat Color
Carcass Final YG
Carcass Hot Weight
Carcass Kill Date
Carcass KPH
Carcass Lot Num
Carcass Marbling Num
Carcass Marbling
Carcass Maturity
Carcass Meat Color
Carcass Muscling Score
Carcass Net Return/Head
Carcass Other Defect
Carcass Other Program
Carcass Packer ID
Carcass Pct Retail
Carcass Prelim YG
Carcass Price
Carcass Quality Grade
Carcass REA
Carcass REA/CWT
Carcass Remark
Carcass Return/CWT
Carcass Return/Head
Carcass Tenderness

Number
Yes/No
Yes/No
Yes/No
Number
Text
Number
Number
Date/Time
Number
Text
Number
Text
Text
Text
Number
Currency
Text
Text
Text
Number
Number
Currency
Text
Number
Number
Text
Currency
Currency
Number

8

50
8
2
8

20
20
30

20

100

0.35
yes
no
no
0.6325
White
2.35
755
5/21/99
2.8
123-95678
55
Moderate
A+
Red
2
23.5
Injection Defect
C.H.B.
XYZ Pack CO
.628
2.50
1.10
Choice 14.6
1.76
Miscellaneous
75.12
882.76
2.87

.35
Yes
No
No
63.25%
White
2.35
755
5/21/99
2.8%
123-95678
55
Moderate
A+
Red
2
$23.50
Injection Defect
C.H.B.
XYZ Pack CO
62.80%
2.0
$1.10
Choice
14.6
1.76
Miscellaneous
$75.12
$882.76
2.87

3.5
30.53
6.1
205.67
0.4975
4.08
16.01
8.45
220
XYZ Feeders
1240
10/1/00
550
627
338-0123

3.5
$30.53
6.1
$205.67
$0.50
$4.98
$16.01
$8.45
220
XYZ Feeders
1240
10/1/100
$550
627
338-0123

0.2
3/21/01
12
4.2

0.2
3/21/101
12
4.2

Feeding Fields
Feeding ADG
Feeding Adj Net Return
Feeding Conversion
Feeding Cost Feeding
Feeding Cost Gain
Feeding Cost Other
Feeding Cost Processing
Feeding Cost Treatment
Feeding Days
Feeding Yard ID
Feeding Final Weight
Feeding In Date
Feeding In Value
Feeding In Weight
Feeding Lot Num

Number
Currency
Number
Currency
Currency
Currency
Currency
Currency
Number
Text
Number
Date/Time
Currency
Number
Text

20

50

Ultrasound Fields
Ultrasound Backfat
Ultrasound Date
Ultrasound Rib Eye
Ultrasound Marbling

Number
Date/Time
Number
Number

Index
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Index
A
A.I.. See artificial insemination
abortion designation
recording 69
active bulls 44, 155
defined 203
active cows 54, 154
defined 203
adding
data entry fields. See customizing:
data entry fields
grafted calf records 61
new cow records 60
remarks (notes or memos)
38, 45, 55, 70, 208
twin calf records 61
adjusted birth weight ratios
calculating 143
adjusted weaning weight ratios
calculating 145
adjusted weight
defined 203
adjusted yearling weight ratios
calculating 146
Adobe Acrobat Reader 196
sample reports 91
alphabetic sort 23
analysis criteria
establishing
using define groups command
39, 41
animal ID
unique 26
animal records
deleting from herd database 153
archive records 148
defined 204

Arrow icon 9
artificial insemination 64
selecting sires 64

B
backup 157, 177
defined 203
Beef Improvement Federation 22, 162
defined 203
BIF. See Beef Improvement Federation
birth date field 44, 54, 68
birth weight ratios, adjusted
calculating 144
birth weight report
calves 118
current table 122
born as field
in Enter Calves window 69
break-even
defined 204
determining 135
breed field
in Enter Bulls window 44
in Enter Cows window 54
breed groups
adding, deleting, customizing 42
breed standards
creating custom 163
breeding command
in enter data > cows menu 62
breeding costs
in cost of production 140
breeding decisions
aided using define groups 39
breeding records, cows
adding multiple 64
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establishing 62
planning and recording
using field forms 87
breeding report 128, 129
breeds
adding. See define groups command
deleting. See define groups command
list of. See define groups command
bull group fields
in Enter Bulls window 44
bull ID field
in Enter Bulls window 44
bull listing report 108
bull records
deleting from herd database 155
bull reports
107, 108, 109, 110, 111, 112, 113
custom 115
bulls
active 44, 155
entering data records 43
gone 44, 155
bulls, replacements 149, 151
buttons
delete 37, 205
find 37, 206
hot 36
navigation 36
new 37, 207
save 37, 208
undo 37, 210

C
calculator
retrieving from within Cow Sense 9
calf archives
defined 204
calf breed field
in Enter Calves window 70
calf death
recording 68
calf field forms 88, 89
calf group fields

in Enter Calves window 70
calf history
defined 204
calf history field
in Enter Calves window 68
calf ID field
in Enter Calves window 68
calf mortality
recording 68
calf ratio summary report
calves 124
calf records
entering 68
calf records, orphans
deleting from herd database 156
calf reports
117, 118, 119, 120, 121, 122, 123, 124, 125
custom 126
calf tabular entry 75
calving dates
establishing estimated 62
calving difficulty
recording 69
calving distribution report 121
calving ease field
in Enter Calves window 69
calving ease report 122
calving report
bulls 109
calves 118
cows 101
calving update 143, 157
carcass data 6
importing 188
cascade icon 9
cascade windows command
in window menu 193
castration date field
in Enter Calves window 71
cattle sales
tracking 135
cell
defined 204

Index

Cesarean section
recording 69
changing directories
in Open Herd window 20, 29, 30, 32
check mark
using in Cow Sense 8
chute-side data collection 86
clone designation
recording 69
cloning
existing herd structure 20, 30
herd data 6
close all windows command
in window menu 193
closeout update 147
cohort
defined 204
columns
closing 81
combined ratio report
bulls 112
command buttons 35
Commercial mode 17
compatibility
of Cow Sense data with other programs 179
concurrent production cycles
in Cow Sense 4
condition field
in Enter Cows window 55
configuration tab 164
contemporary group
defined 204
contents
in help window 195
copying
existing herd structure 30
corrupted database
repairing 179
cost of production
calculating 139
tracking 135
cow breeding records
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establishing 62
Cow COMM
import weight utility 183
cow condition report 101
cow field forms 87, 88
cow group fields
in Enter Cows window 54
cow ID field
in Enter Calves window 68
in Enter Cows window 53
cow listing report 100
Cow Moover 192
cow records
adding 60
deleting from herd database 153
cow reports
98, 100, 101, 102, 103, 104
custom 105
Cow Sense
about Cow Sense 202
commercial 3
demo 18
EZ-75 2
features 1–10
file structure 13
hard drive installation 13
lite 2
main menu bar 8
purebred 3
sample herd 18
starting 17
trial edition 19
updating electronically 201
cow weights
importing 184
Cowboys and Computers 16
cows
active 54, 154
entering records 53
going 54, 154
gone 54, 154
cross breeds
establishing. See define groups
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command
current cycle command
in maintenance menu 143
custom breed standards
creating 163
custom report
bulls 115
calves 126
cows 105
sales 137
custom reports
printing 97
customers
tracking using Sale Manager 3
customizing
breed groups 41
data entry fields 4, 39, 40, 171–
175. See also define groups
command

D
data
defined 204
exporting 5, 6
importing 5, 6, 183
sharing
with other programs/users 3
sharing with other programs/users 6
sorting 22, 165
data entry fields
adding. See customizing: data entry
fields
customizing 39, 40. See also define
groups command
editing. See customizing: data entry
fields
subtracting. See customizing: data
entry fields
data entry mode 193
defined 205
data entry options
establishing 166
data entry windows

explained 36
data exchange
between Cow Sense herds 192
using cow moover 192
using the premium interface component 191
data fields
adding new 171–175
customizing 4, 171–175
editing 171–175
data-collection forms
creating 86
database
defined 204
repairing 179
restoring from backup 178
databases
exporting data to 97
date fields
incrementing / decrementing 38
dates
entering in Cow Sense 38
death, calf
recording 68
decimal places
adjusting 24
decrementing
date fields 38
defaults
defined 205
in data entry 38
define groups command
in enter data menu 26, 39
delete button 37, 205
deleting
data entry fields. See customizing:
data entry fields
deleting herd
herds 31
demo version
unlocking 18, 161
disposal code field 45
disposal date field 45

Index

disposals command
in maintenance > new cycle menu 153
drop-down list. See hot button
defined 205

E
e-mail
Midwest MicroSystems 1, 202
E.T.. See embryos
edit mode
defined 205
editing
data entry fields. See customizing:
data entry fields
several records at once 98. See also
global editing
electronic data exchange
using cow moover 192
using the premium interface component 191
with Midwest MicroSystems
using MicroFTP 197–202
electronic IDs. See E.I.D.
electronic scale weight data
importing into Cow Sense 183
eliminating inactive records from
database 153
embryos
adding records 61
freezing or storing 66
implanting 67
recording transfers 66, 69
enabling
Cow Sense 18
enter cows command
in enter data > cows menu 53
enter data
bulls 43
enter data menu 9, 35
enter sales command
in finance menu 135
EPDs 5
bull
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entering 46
cow
entering 57
defined 205
importing data 188
reports 104, 113
estimated calving dates
establishing 62
exchanging data
using the premium interface component 191
with other programs/users 6
exiting
Cow Sense 34
expected progeny differences. See EPDs
exporting data 5, 6, 97
EZ-75 mode 17

F
features
of Cow Sense 1–10
feedlot data 6
importing 188
field forms
calf 65, 88, 89
cow 52, 87, 88
creating 86
defined 206
fields
adding or customizing 171–175
choosing for data entry 166
defined 205
file
creating new herd 30
defined 206
file menu 9, 29
file structure
in Cow Sense 13
finance menu 9, 135
find button 37, 206
find command
in help > search menu 195
form

220

Cow Sense User’s Guide

defined 206
format
defined 206

G
global editing 98
going cows 54, 154
defined 203
gone bulls 44, 155
defined 203
gone cows 54, 154
defined 203
grafted calf records
adding 61, 66
grids
closing 81
resizing 81
groups
defining
in enter data menu 39

H
hay costs
in cost of production 140
health costs
in cost of production 140
heifers, replacement 149
help 10. See also support
contents 195
on-line 9
print 196
search 195
using the user’s guide 196
help menu 9, 194
herd analysis
setting up
using define groups 39
herd file
retrieving from Midwest MicroSystems support 199
sending to Midwest MicroSystems
197

herd files
backing up 177
deleting 31
repairing 179
restoring from backup 178
herd health. See treatments
herd inventory
updating 149
herd name 21
defined 206
herds
cloning 20, 30
deleting 31
opening different 29
starting new 19, 30
hot button 36
using to activate data entry mode 193

I
icons
on main menu toolbar 9
IDs
uniqueness of 39
importing data 5, 6, 183–192
using the import tool 188
using the premium interface component 191
weights 183, 184, 185, 187
incrementing
date fields 38
index
defined 206
index command
in help > search menu 195
individual summary report
bulls 107
calves 117
cows 98
information flow
in Cow Sense 7
installing
Cow Sense 13
interest costs

Index

in cost of production 140
inventory command
in maintenance > administration
window 170

L
labor costs
in cost of production 141
leading year sort 23
library
of sample reports 92, 93
licensing
Cow Sense 17
listed options
using the hot button 8
Lite mode 17
logical operator 94, 136

M
mailing labels
printing using Sale Manager 3
main menu bar
in Cow Sense 8
maintenance menu 9, 143
management decisions
aided using define groups 39
marketing methods
analyzing 135
marking records
using the Checkmark 8
marking tool 95
match function 133
medications. See treatments
memo. See remarks field
menu
defined 206
main menu toolbar 9
metric weights 24
MicroFTP 197–202
Midwest Micro Systems
telephone number 202
Midwest MicroSystems

221

e-mail address 1, 202
telephone number 1
web page 1, 202
modes
of Cow Sense 2, 3, 17
mortality, calf
recording 68
MPPA
defined 206

N
natural service 65
navigation
buttons 35
tool bar
in Enter Data windows 35
tools 8
new button 37, 207
new cow records
adding 60
new cycle command
in maintenance menu 148
new herd
creating 30
notes. See remarks field
numeric sort 165

O
open cow designation
recording 69
open herd command
in file menu 29
opening
Cow Sense 17
operators
defined 207
logical 94, 136
relational 94, 136
options list
retrieving using hot buttons 8
orphan calf records
creating 61
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deleting from herd database 156
overhead costs
in cost of production 141

P
page orientation
in printer setup 33
pages
explained 36
paper size
in printer setup 33
pasture costs
in cost of production 141
PDF
sample reports 91
pedigree report
bulls 108
pedigrees
entering 46, 56
pelvic area measurement
entering 150, 152
performance report
cows 104
post cow command
in enter data > cows menu 60
preg check records
planning and recording
using field forms 88
pregnancy evaluations 5
entering data records 56
Premium Interface Component 191
printed forms
creating 86
printers
setting up 32
printing
custom reports 97
reports 5, 95
process date 21
processing tab 21, 162
production costs
calculating 139
production cycle

current cycle 143
defined 207
in Cow Sense 4, 26
selector 4
starting new 157, 168
production summary report
calves 125
progeny report
bulls 108
promoting
bull calves to herd or A.I. bulls 151
heifers to cows 149
purchased calves
creating records for 61
Purebred mode 17

Q
query 93
creating 79, 91, 150, 152
defined 4, 207
in remarks field 39
tool bar 91
question mark icon 9
quitting
Cow Sense 34

R
raised as field
in Enter Calves window 69
ratio analysis report
bulls 111
ratios
birth weight
calculating 144
defined 208
weaning weight
calculating 145
yearling weight
calculating 146
records
defined 208
deleting from herd database 153

Index

selecting. See queries
registration number 18, 161
finding in Cow Sense 202
relational operator 94, 136
remarks field 38
defined 208
in Enter Data window 45, 55, 70
repair herd command
in utilities menu 179
replacements
adding
bulls 149, 151
heifers 149
replacements command
in maintenance > new cycle menu 149
reporting year 21
reports
breeding 128, 129
bulls
107, 108, 109, 110, 111, 112, 113
calves
117, 118, 119, 120, 121, 122, 123, 124, 125
cows 98, 100, 101, 102, 103, 104
custom
breeding 129
bulls 115
calves 126
cows 105
sale 137
identifying 97
printing 5, 95
sale record 136
samples 5, 91
treatments 131
reports menu 9, 91
resizing
grids 81
restore from backup command
in utilities menu 178
run new cycle command 4
in maintenance > new cycle menu 157
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The Utilities Menu

1

Cow Moover
Cow Moover is a utility program within Cow Sense that lets you
move whole-herd cow and bull tables into other herd data sets. Essentially
you append one herd’s cow and bull tables unto another when you use Cow
Moover. You also have the option of transferring a cow’s current calf and
past progeny records along with her records when you use this utility.
To use Cow Moover, click Utilities > Cow Moover from the main
menu bar. Cow Sense will open the Cow Moover program (see Figure 1).
You must purchase an enablement key to fully operate Cow Moover, but you
can see how it work by using the Cow Moover trial edition first. Call Midwest MicroSystems at 800-584-0040, or contact your Midwest MicroSystems
Reseller if you wish to acquire an enablement key.
FIGURE 1.
THE COW M OOVER SHELL
AND IDENTIFY HERDS
WINDOW .

To move cow or bull records (with or without past progeny records)
from one herd into another herd, select Transfer Cattle > Identify Herds
from the Cow Moover main menu bar. Cow Moover will display an Identify
Herds window (see Figure 2). Using standard Windows protocol, select the
folder and file for your Source Herd. The Source Herd contains the tables

2

Chapter 8

FIGURE 2.
THE COW M OOVER IDENTIFY
HERDS WINDOW .

that you want to append into the Destination Herd. The default directory for
the Source Herd is c:\cowsense\herds. After you have selected the Source
Herd, use standard Windows protocol to select the folder and file for your
Destination Herd. The Destination Herd is the data file that will receive
records from the Source Herd. Click the Continue button.

“MOOVING” COWS
Transferring cow records from one herd file to another involves a
three-step process. First you set up the files, then you select the records you
want to “moove” and then you process the files, which is the actual transfer
process.

SET UP
FIGURE 3.
THE COW M OOVER SET UP
COWS WINDOW .

To set up cow records to
move, select Transfer Cattle >
Moove Cows > Set Up Cows from
the Cow Moover main menu bar to
open the Set Up Cows window (see
Figure 3). After you have finished
setting up the way you want data to
transfer from the source to the
destination file, click the Continue
button. Cow Moover will automatically open the Select Cows window for you to complete the next step.
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Source Records
You have two options in the Source Records box of the Set Up Cows
window. If you select the Flag as Gone radio button, the Status field in all
records that you transfer from the source herd will change to “Gone”. If you
select the Delete From Source Herd radio button, Cow Moover will delete all
the records that you transfer from the source herd; you cannot undo the
deletions if you chose this option.
Archives
If you select the Copy to Destination Herd radio button, Cow
Moover will transfer all the cow herd’s past progeny records with the cow
records from the source herd into the destination herd, or leave them out.
These records do not include the cow herd’s current calf crop records. If you
select the Do Not Copy to Destination Herd radio button, Cow Moover will
not transfer past progeny records.
Current Calves
If you select the Copy to Destination Herd radio button, Cow
Moover will transfer the cow herd’s current calf crop records with the cow
records from the source herd to the destination herd. If you select the Do Not
Copy to Destination Herd radio button, Cow Moover will not transfer current
calf crop records. You must have calf records established in both the source
and the destination herds in order for this transfer process to work.
Groups
If you select the Add Group to Destination Herd radio button, Cow
Moover will transfer Cow Group 1 and Cow Group 2 headings from the
source herd to the destination herd. If you select the Remove Group IDs
radio button, Cow Sense will not transfer Cow Group 1 and Cow Group 2
headings from the source herd to the destination herd. See the Enter Data >
Define Groups section in Chapter 4 of the Cow Sense User’s Guide for more
information on Cow Groups.

SELECT COWS
To select which cow records you want to move, select Transfer
Cattle > Moove Cows > Select Cows from the Cow Moover main menu bar
to open the Select Cows window (see Figure 4).
Use the Select button in this window to use the query functions in
order to obtain the cow records in the source file that you want to transfer.
See Chapter 5 of the Cow Sense User’s Guide for more information on using
the query functions.
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FIGURE 4.
THE COW M OOVER SELECT
COWS WINDOW .
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You can
mark or unmark all
the records present
in the open grid by
clicking the appropriate button. If you
want to mark
animals individually
in the open grid,
place your mouse
cursor to the left of
the Cow ID field.
The cursor will
change to an arrow. Click the mouse. Marked records will be black.
Once you have marked the cow records you want to transfer, click
the Select Marked button. Cow Moover will count the records that you have
selected and give you value in the Tally box. When you are satisfied that you
have all the records selected that you want to transfer click the Done Selecting button. Cow Moover will automatically launch the Process Cows window.

PROCESS COWS
FIGURE 5.
THE COW M OOVER
PROCESS COWS WINDOW .

To complete the transfer
process, select Transfer Cattle
> Moove Cows > Process
Cows from the Cow Moover
main menu bar. Cow Moover
will display a Process Cows
window (see Figure 5). This
window will list the source and
destination herds, and show a
Tally of records selected and
validated to transfer. Once the
transfer is complete, the Tally window will display the number of records
successfully transferred. Click the Process Cows button to proceed. A Back
Up Destination Herd window will appear. Click the Yes or No button to
proceed.
Cow Moover will display a Transfer Cows window (see Figure 6) as
one last check point to be sure you have selected the right number of records
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to transfer, and have set the right
parameters. Click the Yes button if it
is OK to proceed. Then in the Tally
box of the Process Cows window,
Cow Moover will display the
number of records successfully
transferred. Click the OK button in
the Cow Transfer window to finish
the process.

FIGURE 6.
THE COW M OOVER TRANSFER COWS WINDOW .

“MOOVING” BULLS
Transferring bull records from one herd file to another involves a
three-step process. First you set up the files, then you select the records you
want to “moove” and then you process the files, which is the actual transfer
process.

SET UP
To set up bull records to move,
select Transfer Cattle > Moove Bulls
> Set Up Bulls from the Cow Moover
main menu bar. Cow Moover will
display a Set Up Bulls window (see
Figure 7). After you have finished
setting up the way you want data to
transfer from the source to the destination file, click the Continue button.
Cow Moover will automatically open
the Select Cows window for you to
complete the next step.
Source Records
You have three options in the Source Records box of the Set Up
Bulls window. If you select the Leave in Source Herd radio button, Cow
Moover will not change the status nor delete transferred bull records from
the source herd. If you select the Flag as Gone radio button, the Status field
in all the records you transfer from the source herd will change to “Gone”. If
you select the Delete From Source Herd radio button, Cow Moover will
delete all the records that you transfer from the source herd; you cannot undo
the deletions if you chose this option.

FIGURE 7.
THE COW M OOVER SET UP
BULLS WINDOW .

6

Chapter 8

Groups
If you select the Add Group to Destination Herd radio button, Cow
Moover will transfer Bull Group 1 and Bull Group 2 headings from the
source herd to the destination herd. If you select the Remove Group IDs
radio button, Cow Sense will not transfer Bull Group 1 and Bull Group 2
headings from the source herd to the destination herd. See the Enter Data >
Define Groups section in Chapter 4 of the Cow Sense User’s Guide for more
information on Bull Groups.

SELECT BULLS
FIGURE 8.
THE COW M OOVER SELECT
BULLS WINDOW .

To select
which bull records
you want to move,
select Transfer
Cattle > Moove
Bulls > Select Bulls
from the Cow
Moover main menu
bar. Cow Sense will
open a Select Bulls
window (see Figure
8).
Use the
Select button in this window to use the query functions in order to obtain the
bull records in the source file that you want to transfer. See Chapter 5 for
more information on using the query functions.
You can mark or unmark all the records present in the open grid by
clicking the appropriate button. If you want to mark animals individually in
the open grid, place your mouse cursor to the left of the Bull ID field. The
cursor will change to an arrow. Click the mouse. Marked records will be
black.
Once you have marked the bull records you want to transfer, click
the Select Marked button. Cow Moover will count the records that you have
selected and give you value in the Tally box. When you are satisfied that you
have all the records selected that you want to transfer click the Done Selecting button. Cow Moover will automatically launch the Process Bulls window.
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PROCESS BULLS
To complete the transfer
process, select Transfer Cattle >
Moove Bulls > Process Bulls
from the Cow Moover main menu
bar. Cow Moover will display a
Process Bulls window (see Figure
9). This window will list the
source and destination herds, and
show a Tally of records selected
and validated to transfer. Once the
transfer is complete, the Tally
window will display the number of records successfully transferred. Click
the Process Bulls button to proceed. A Back Up Destination Herd window
will appear. Click the Yes or No button to proceed.
Cow Moover will display a
Transfer Bulls window (see Figure 10)
as one last check point to be sure you
have selected the right number of
records to transfer, and have set the
right parameters. Click the Yes button
if it is OK to proceed. Then in the Tally
box of the Process Bulls window, Cow
Moover will display the number of
records successfully transferred. Click
the OK button in the Bull Transfer window to finish the process.

FIGURE 9.
THE COW M OOVER
PROCESS BULLS WINDOW .

FIGURE 10.
THE COW M OOVER
TRANSFER BULLS WINDOW .

