
  

Guide to Herd Conversion 
 
 
Conversion of Cow Sense Version 4 data to a Cow Sense NxGen herd file 

Discussion:  The purpose of this Product Support Bulletin is to outline the steps required for 
converting Cow Sense version 4 (v. 4.0) data to a Cow Sense NxGen herd file. 

 
1. Are you currently at Cow Sense version 4.85 (v. 4.85)?   

 The Current Cow Sense Version number is displayed when you first launch 
Cow Sense (middle of the screen underneath the logo); above the Main Menu of the 
Cow Sense Home Screen; or from the Main Menu choose Help > About 
Cow Sense.  If you are at v. 4.85 continue to Step 2, if not, please go to the Cow 
Sense Corral (www.cowsensecorral.com) to download the latest version. 

o If you do not remember your Cow Sense Corral login, click on Send my 
login! to have it emailed to you. 

o After you have logged into the Corral, click on the Downloads button. 
o Under Full Installs, click on Cow Sense v. 4.85. 

If you are pre-Cow Sense v. 4.0, you will need to purchase the v. 4.0 upgrade. 
 

2. Review your current Cow, Calf, and Bull inventories. 
 In Cow Sense v. 4.0, go to Maintenance > Administration > Inventory.  
 

 
 
 Your Cow Sense Inventory Summary will appear.  This inventory summary lists 

the number of all Active and Gone cows, calves, and bulls in your Cow Sense herd.  
 

 
 

o When reviewing your inventory, verify the correct number of cows, calves 
and bulls are appearing as Active.   

 If your inventory contains too many Active animals, you will need 
to change cow/calf/bull status to Gone. (steps shown below)  

o *Note: Your inventory report may contain more than one page.  Click the 
arrow buttons at the top of the Inventory Report to scroll through all pages 
available. 
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If your Active animal inventory contains too many animals: 
A. For cows: go to Enter Data > Cows > Enter Cows.   

 Click the Find button and type in the ID of the cow needing to be marked Gone.  
Change the cow’s status from Active to Gone. 

B. For bulls: go to Enter Data > Bulls > Enter Bulls. 
 Click the Find button and type in the ID of the bull needing to be marked Gone.  

Change the bull’s status from Active to Gone. 
C. For calves: Create a custom calf report by going to Reports > Calves > Custom. 

 Choose **Active Calves** from the Selection drop down list to see all active calf 
records in your herd.  
 

 
 

 To narrow down the fields (columns) that appear in the report, click the Setup 
button to select the data fields you’d like to see in your report.  Be sure to include 
Status.  
 

 
 

 To narrow your calf selection further, click the Select button. 
 

 
 

o Here, you can create a selection for calves born in a certain year, or who 
were included in a certain production cycle. 

 Note: if you have promoted replacement heifers or bulls through 
Maintenance > New Cycle > Replacements, the Status of these 
calf records have already been changed to Gone and exist as Cow 
or Bull records. 
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 When you have completed narrowing down your selection of calves that should no 
longer be “Active,” use the Global Edit button to change all selected calves to 
Gone.  

 

 
 

o Global Edit is located on the far right of the button bar menu and looks 
like a small Earth or Globe. 

 The Global Edit window will open, under Select Fields for 
Changing Data, click the drop down arrow and scroll to Status. 

 Under Target Data, click on the Change All Values button. 
 Under Edit Type, choose Replace With Value and select Gone 

from the drop down box. 
 Click Apply Change. 

 
 *Note on calf histories: 

o Calf History of 99 (Missing Data): Calf records with this history code will 
not be copied into the NxGen herd file. 

 If you know the appropriate outcome for the calf, make the change 
in the v. 4.85 production cycle. 

o Calf Histories of 80, 81, 82 (Embryo):  EZ Edition does not offer embryo 
management. Calf records with these history codes will not be copied into 
the NxGen herd file. 

 If these history codes were over-looked, and there was a live calf 
(or loss) that resulted from the transplant, change the calf history 
to account for the calf accordingly. 

o Calf History of 9 (Bred Cow Sold): A record with this history code will not 
be copied into the NxGen Herd file.  This is used for a cow outcome in 
Cow Sense v. 4.0 that is not relevant in NxGen. 

o Calf Histories 6-8 (Abortion, Open Cow, Bred Cow didn’t calve): These 
records are copied into NxGen as a breeding outcome.  Version 4.0 Calf 
History Codes of 7 and 8 will be recorded as “Failed to Conceive”, whereas 
Calf History of 6 will be recorded as “Abortion”. 

o Calf Histories 1-5 (Live calf, calf deaths): These records are copied into 
NxGen as an animal record. 

 
3. Re-review your Inventory Summary.  

 Make any other changes to your Active Animal Inventory using the steps above 
until the correct number of cows, calves and bulls are shown as active. 

 Make a backup of your Cow Sense v. 4.85 herd by going to Utilities > Local 
Backup/Restore > Local Backup. 

o For complete backup instruction, please view our Product Support Bulletin 
for Herd Backup/Restore here: 
http://www.midwestmicro.com/docs/psb/psb008.pdf 

 
4. Verify Links 

 Prior to converting your Version 4 herd file to NxGen, we suggest you run a utility 
program we built to verify all the internal record links.  This Utility is found in the 
Cow Sense Corral on the Downloads page.  Scroll down to find V4 Service Packs, 
and open Verify Links v1.0.  The direct link is: 
http://www.mmsweb.us/servicepacks/ver_link.exe. 
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 Download and Save the program locally, then proceed to Run the program.  Check 
that the correct herd file is selected and click Yes on the Verify Links page to run the 
program.  By default, the Verify Links Service Pack will connect to the last herd file 
you had open in Cow Sense Version 4.  Click No on the Verify Only page to allow 
the program to both verify and fix any linking issues found in the data.  Your Cow 
Sense Herd File must be closed in order for the program to fix any data.  Again, 
make sure you have a backup before completing this step, as directed in Step 3. 

 
 

 
 Open, Review, and save the log file to a location you can easily find.  If there are 

issues cited as the program reviews your version 4 herd that are of concern, please 
send a copy of the log file created to support@cowsense.com for further analysis.  If 
there are no issues reported by this process, proceed with conversion of your version 
4 herd to NxGen.   

 
5. If you have not already done so, install Cow Sense NxGen on your computer using the 

following link: http://www.cowsense.com/ng/ 
 Select Download Cow Sense NG. 
 Save the download file. 

o By default, the file will be saved to your Downloads folder. 
 Run the downloaded file and install Cow Sense NxGen. 

 
6. Once Cow Sense NxGen is installed, the program will be in Trial Mode. When you are ready 

to activate the program, launch NxGen and choose the Activate option.  
 Please note the Registration Number displayed.  Email this number to 

admin@cowsense.com to request activation.  We will then send you an Activation 
Key, which will remove the Trial limitations. 

 You will also need your Serial Number to activate Cow Sense NxGen.  If you do 
not have your Serial Number, you can find that information in My Account at the 
Cow Sense Corral.  You may also request this information by emailing 
admin@cowsense.com. 
 

7. After Cow Sense NxGen has been activated, create a New herd of your own. 
 To create a new herd file (.csh), go to File > New.  Enter the name you wish to call 

your herd file, and click Save.  
o By default, NxGen herd files (.csh files) are saved to your computer’s 

Documents folder, in the subfolder Cow Sense. 
o To see complete instruction on how to create a new herd file, please see 

page 9 of the NxGen Quick Start Guide in the Help > Quick Start Guide 
menu in Cow Sense NxGen. 

o Hint: After you have created your herd file and adjusted field settings from 
the Options Menu > Data Filed Settings.  Make a Backup of the NxGen 
Herd File.  See NGG_003 Guide to Herd File Backup and Restore. 
 

8. If Cow Sense NxGen is being installed on a different computer than where Cow Sense v. 4.85 
currently resides: 

 Make another backup of your Cow Sense v. 4.85 herd on removable media (such as 
a flash drive) by going to Utilities > Local Backup/Restore > Local Backup.  Note 
that this backup should be made AFTER using the Verify Links Utility. 

 Insert your removable media into the computer that is running Cow Sense NxGen. 
o You may leave the backup on the flash drive, or you can copy and paste the 

file to a convenient location on your computer, such as the Desktop. 
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9. If Cow Sense NxGen is being installed on a computer that is running Cow Sense v. 4.0, the 
Herd Converter will look to the old v. 4.0 Cow Sense Herds folder and confirm the herd 
file. 

 Note: If you are using XP Mode or Virtual Box, the Herd Converter will not be 
able to automatically navigate to these folders.  You will need to follow the steps in 
Step 8. 
 

10. Run the Cow Sense Herd Converter in Cow Sense NxGen by going to File > Convert.  
 To see complete instructions on converting your herd file, please see page 9 in the 

NxGen Quick Start Guide in the Help > Quick Start Guide menu in Cow Sense 
NxGen. 

 It is important to note that an option now exists to add pedigree reference animals 
through the conversion process.  In the Version 4 Purebred program, pedigrees could 
be built by either linking sires and dams to their progeny or typing the names into 
the pedigree tab of the Enter Cows or Enter Bulls screen.  Checking the option “Add 
pedigree reference animals” will direct the converter to check animal names in the 
pedigree against existing records in Cow Sense.  If it does not find an exact match 
for these names as existing animal records in Version 4, it creates animal records for 
these names so they will appear in the NxGen herd file as pedigree references.  This 
option will make duplicate animal records if the animal exists with a slight variation 
of the name that was typed into the pedigree.  Use it with caution.  You may wish to 
do a trial conversion to review the results. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

11.  Review the Log File. 
 If there are errors reported in the Log File, review and fix the data in Cow Sense 

v.4.0.  Repeat the steps above to change your active animal inventory and to make a 
backup of your v. 4.0 herd file. 

 If you are going to run the Herd Converter again, delete the previously created 
Cow Sense NxGen herd file (.csh file) and create a new one.  Alternatively if you 
made a back up of the blank NxGen Herd file as suggested in Step 7, you can simply 
restore to that file and re-run the conversion. 

 
12. After you are satisfied with the herd conversion, review your Active Animal Inventory in 

Cow Sense NxGen using either the Individual Animal or Animal List view.   
 Both are found under the Manage menu in NxGen. 

 
13. To preserve your Version 4 data in a form that is always accessible, you can Export the data 

you wish prior to Transferring the License.   
 From the v. 4.0 Main Menu choose Utilities > Transfer Data > Export and choose 

the data you wish to export. 
 This action will export key analytic data to a Tab Delimited Text file (.txt) that can 

be opened with spreadsheet software.   
 Give the file a name and by default it will be saved in the Cow Sense Directory in 

the Export Folder.  
 Repeat the process for all data you wish to preserve in this form. 
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14. Any Custom Fields in use will not be transferred from Version 4 to NxGen through the herd 

conversion. 
 First, check to see if your previous Custom Fields already exists in NxGen by 

looking through the list located at Data Field Settings>Standard Fields from the 
left sidebar menu.  If you find a field you wish to use, toggle it on.  Then Export the 
data from your Version 4 Custom Field and Import it into the corresponding NxGen 
field.   Refer to the NxGen Video Tutorial and Script Notes for the Import tool for 
more information regarding this function. 

 If no field in NxGen relates to your Version 4 Custom Field, you may create a 
Custom Field in NxGen at Data Field Settings>Custom Fields and use the same 
process as above to Export and Import your data. 

 
15. If Treatments are recorded in Version 4, these will not be transferred through the herd 

conversion.  Please contact Cow Sense Support for help moving your Treatment records into 
NxGen. 

 
16. For Version 4 Cow COMM Pro users, the Historical Measures table will not be transferred to 

NxGen through the standard herd conversion process.  Again, please contact Cow Sense 
Support for help moving measures into NxGen.  

 
17. When you are satisfied with the converted data, complete the Transfer process from Cow 

Sense v. 4.0. 
 From the v. 4.0 program Main Menu choose Help > Transfer License. 
 Follow the prompts to remove and transfer your license to complete the Cow Sense 

NxGen upgrade process. 
 

Please contact us at support@cowsense.com or 800-584-0040 for any questions or assistance. 
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