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Introduction 

Overview of Cow COMM 

Cow COMM™ is a revolutionary product that provides for real time individual management of 

your herd.  It is a communications component of the Cow Sense® suite of products that provides 

both an active or Chute-side interface and a passive or Post-processing interface with electronic 

data collection devices.  In the Chute-side environment, Cow COMM allows for instantaneous 

interaction (real-time) with the Cow Sense database.  In this chute-side environment, there are 

advanced features in Cow COMM that can also be used for real time sorting of cattle.  Cow 

COMM can also be very useful for user’s through a Post-processing interaction to retrieve data 

collected in scale indicators or RFID readers and automatically update data in Cow Sense.  The 

information obtained while using Cow COMM is actually stored and resides in your Cow Sense 

herd file.  Cow COMM runs as a separate program but it depends upon Cow Sense to function.  

It contains no reporting or analysis tools of its own.  However, Cow COMM Pro features are 

available (as an upgrade) and add capabilities for recording, storing and exporting repetitive 

measurements over time. 

Figure 1: The Cow Sense Suite of Products 

 

Changes to a record are saved when you move off the record.  However, it is recommended that 

you back up your Cow Sense Herd each time you quit Cow Sense.  This will automatically 

institute a check and balance procedure to resave all of the information you obtained while using 

Cow COMM. 
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Please note that Cow COMM is designed to work with Cow Sense version 4 or higher. 

Key benefits of Cow COMM: 

• Increased profit through individual animal management. 

• Rapid, objective application of predetermined decision criteria. 

• Real time access to complete animal history for decision process. 

• Enhanced speed and reliability of automated data acquisition. 

Features of Cow COMM 

Cow COMM has so much to offer.  In addition to allowing for retrieval of an animal’s record 

from Cow Sense, this program allows for automatic recording of animals’ weights when 

connected to compatible electronic scales.  The retrieval of an animal’s record can also be 

automated when using Radio Frequency Identification (hereafter referred to as RFID) equipment.  

Both functions are possible through the connection of these chute-side devices (i.e. the RFID 

reader and the electronic scale) with your computer’s communications ports. 

Another extremely powerful feature of Cow COMM is its Auto Sort function.  This feature 

provides the ability to sort your cattle into any type of groups that you want – you decide!  After 

you specify how you want to sort your cattle, Cow COMM will quickly and accurately perform 

the necessary calculations right while the animal is standing in front of you!  Please note that for 

the Auto Sort function, you define the sorting groups before you process your cattle.  In this way, 

processing the cattle at chute-side will be quick and easy.  The Auto Sort features are at 

additional cost and discussed in more detail on pages 41-46 of this document. 

User Tips 

It is recommended that you experiment with the Cow COMM application before working live 

cattle.  Test the RFID reader and/or electronic scale indicator to insure its compatibility with the 

RFID devices you are using.  You should also field test your RFID reader(s), and keep an 

additional RFID reader available. 

Customer Service Policy 

We believe that individuals who need extra technical assistance should bear the cost of that 

service, rather than inflating the price of Cow COMM for everyone.  Therefore, we include 30 

minutes of telephone technical support with purchase to ensure that you get started well, but 

charge for support time after that.  Your included support period begins with the first support 

contact following activation of your Trial Edition.  To receive support: 

1. Check this User’s Guide first. 

2. Point your Internet browser to http://www.cowsensecorral.com to access the Knowledgebase of 

answers to common questions or go to User’s Forum (also at the Corral) and into the Cow COMM 

section. 

3. Send e-mail to support@midwestmicro.com.  

4. Call Midwest MicroSystems at (800) 584-0040. 

Please have your Cow Sense serial number and your Cow COMM registration number handy 

when you call for support.  The serial and registration numbers are located in the Cow COMM 

Trial Edition screen that appears when you first open Cow COMM.  If you are already working 
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in the program, you can find these numbers on the About Cow COMM message box when you 

select Help > About from the Cow COMM Main Menu. 

Updates 

Updates can be obtained in one of three ways. 

1.  Automated updater.  For the smaller version updates that are downloaded in this manner, 

there will not be an update fee or charge.  Occasionally, some firewall or Internet security issues 

block this type of update.  If you experience this, try turning off your firewall or Internet 

security. 

a. Open a connection to the Internet. 

b. Launch Cow COMM. 

c. Go to Help > Cow COMM Support > Update Cow COMM > Yes (to 

Retrieve Update via FTP) > Launch MicroFTP > Connect.  This process 

will download the most current version of Cow COMM from our FTP site. 

d. At the end of the download, you will be notified that the session was complete, 

click “OK”. 

e. Upon clicking “Exit” in the Connect window, a message will be displayed 

indicating that the “File transfer was successful and to proceed with the 

update”, click OK. 

f. A “WinZip Self-Extractor window will open and you will need to click the 

“Setup” button for the update to run.  A “Setup succeeded!” window will open 

and you will click “OK”. 

2.  You can download direct from our web site.  For the smaller version updates that are 

downloaded in this manner, there will not be an update fee or charge.  Occasionally, some 

firewall or Internet security issues block this type of update.  If you experience this, try turning 

off your firewall or Internet security and running the update again. 

a. Go to www.cowsense.com and go to Downloads, choose Updates and navigate 

to the Cow COMM section. 

b. In the Cow COMM update section click on the link to start the download 

process.  Allow the download to “RUN” at all security checkpoints.  At this 

point you should see the file transfer begin. 

c. A “WinZip Self-Extractor window will open and you will need to click the 

“Setup” button for the update to run.  A “Setup succeeded!” window will open 

and you will click “OK”. 

3.  You can also call or email us to receive an update CD.  There is a charge for this update to 

cover the CD and shipping.  Instructions will accompany the CD for this type of update. 

Upgrades 

The Cow COMM Trial Edition does not expire and you may activate it at any time.  All registered 

Cow COMM users will be notified of future upgrades as they become available.  To purchase these 

upgrades, call your Midwest Microsystems Reseller or call Midwest MicroSystems directly at 800-

584-0040.  You may also send e-mail inquiries to sales@midwestmicro.com or check the Midwest 

Microsystems web site at http://www.cowsense.com. 
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Information Flow  

Figure 2 gives you a graphical representation of how information flows within Cow COMM and 

how information flows between Cow COMM and Cow Sense.  As stated previously, Cow 

COMM is a companion to Cow Sense.  Data collected through Cow COMM is stored in Cow 

Sense. 

Figure 2: Cow Sense/Cow COMM Information Flow 

Start Cow COMM

Work Cattle

Exit Cow COMM

Cow Sense 

Herd

Define Work 

Settings

Initial Set Up

Cow Sense 

Reporting

 

Organization of this Document 

This document is organized to follow the natural progression through the Cow COMM Main 

Menu screen. The reader is guided through each menu item with its associated tasks and related 

features.  Detailed instruction per use of the advanced functionality of Cow COMM Pro and the 

Auto Sort capabilities are located at the back of this document.  This organization style provides 

a direct reference as questions arise per the specific function and necessary method(s) to 

accomplishing the task.  We are pleased to provide you with this useful tool and stand at your 

service to ensure your optimum benefit of its use.
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INSTALLING COW COMM 

Cow COMM is installed automatically when the Cow Sense Suite is installed.  No separate 

installation is necessary.  However, Cow COMM does require it’s own activation key.  

Following the purchase of the program, you will need to contact Midwest MicroSystems or your 

Reseller to obtain an activation “key” (a unique coded number that “unlocks” the Cow COMM 

Trial Mode on that specific computer).  Provide Midwest MicroSystems or your Reseller with 

your Cow Sense serial number and your Cow COMM registration number in order to obtain your 

key.  The serial and registration number are located in the Cow COMM Trial Edition screen that 

appears when you first open Cow COMM (see Figure 3).  If you are already working in the 

program, you can find these numbers on the “About Cow COMM” message box when you select 

Help > About from the Cow COMM Main Menu. 

Figure 3: Cow COMM Trial Edition 

Select the Enter Key button on this screen and you will type in your activation key, as provided 

by Midwest MicroSystems or your Reseller, (replace all the zeros) in the open field (see Figure 

4). 

Following entry of your activation key, select Save and 

you will be instructed to restart the Cow COMM 

program so that your activation will take effect.  When 

you select OK, Cow COMM will automatically shut 

down and you will then restart the program.  In order to 

restart the program, select the Windows Start button > 

Programs > Cow Sense > Cow COMM.  You can also 

launch Cow COMM from the icon Menu Bar in Cow 

Sense.  With Cow Sense open, simply select the Cow  

COMM Icon          .  It is suggested that you create a “short-cut” icon to Cow COMM on your 

desktop.  Please refer to Windows Help for specific instructions on creating short-cuts. 

 

Figure 4: Enter Key 
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Figure 6: Open Herd 

 
 

  

 

COW COMM MAIN MENU 
When Cow COMM is launched, the first screen that appears is the Cow COMM Main Menu 

(see Figure 5). 

Figure 5: Cow COMM Main Menu 

The Main Menu allows you to choose 

from four functions: File, Set Up, 

Activity, and Help.  Note that the last 

text line on this screen displays the 

Cow Sense Herd which is currently 

open.  When you first open Cow 

COMM, the Herd displayed will be the 

Herd in which you were last working 

with either Cow Sense or Cow COMM 

(whichever program was closed most 

recently). 

File Function 

Open Cow Sense Herd 

If you are using Cow COMM in Trial Mode, you will be limited to working only with the Cow 

Sense Sample Herd.  From the Cow COMM Main Menu, if you select File > Open Cow Sense 

Herd without having a Cow COMM key, a message box will appear reminding you that you 

cannot open up another herd without entering an activation key. 

If you have already obtained an activation key for Cow COMM and have entered another Herd 

into your Cow Sense program, you will be able to 

choose which Herd you want to use with Cow COMM.  

From the Cow COMM Main Menu, select File > Open 

Cow Sense Herd. 

An Open Cow Sense Herds screen (see Figure 6) will 

appear allowing you to choose from your personalized 

list of existing Herds in the Cow Sense Herds folder.  

All available Herds should appear in the left-most 

scroll box of this screen.  Select (double left mouse 

click) the Herd with which you want to work. 

Start Cow Sense 

It is not necessary for your Cow Sense program to be open in order for you to enter the new data 

you will record using Cow COMM.  However if you wish to view reports or the records in your 

herd file, you can do so by opening Cow Sense.  If you have not already opened your Cow Sense 

program, this feature allows you to do so without exiting Cow COMM.  From the Cow COMM 

Main Menu, simply select File > Start Cow Sense.  Cow Sense will launch using the Herd that 

is displayed on the Cow COMM Main Menu screen. 
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Figure 8: Serial Communications Port 

 

Exit 

When you are ready to quit, or exit Cow COMM, select the File > Exit command from the Cow 

COMM Main Menu.  You can also quit Cow COMM by selecting the  icon in the upper right-

hand corner of your Cow COMM screen or by double clicking the control box in the upper left 

corner of your screen.  A message box will ask you if you are sure you want to quit.  Select Yes 

or No. 

If you had Cow Sense open, and have exited Cow COMM, Cow Sense will remain open.  If you 

would like to exit Cow Sense as well, proceed to the Cow Sense Main Menu.  The method of 

exiting the program is the same as for Cow COMM.  In this case, however, a Back Up Herd? 

message box will appear, recommending that you back up your Herd.  Select Yes or No. If you 

select No, you will exit Cow Sense without a back up being made of your Herd.  If you select 

Yes, a Back Up Herd screen will appear.  The Backup file is saved by default to the Herdsbak 

file folder in Cow Sense (see Figure 7). 

Figure 7: Back Up Herd 

When you backup a herd, Cow Sense looks for the sequence 

number of the last backup of the current herd (stored in the 

file extension), increments it, and copies the current herd to 

the Herdsbak directory with the new sequence number as the 

extension.  This way, Cow Sense keeps track of your 

backups, and you can see what the backup history is for a 

given herd.  You aren’t limited to that backup option, 

however. Cow Sense will also let you back up to a flash drive or other removable media, to 

another directory, or to another hard drive.  Cow Sense provides a name for the backup, using the 

incremented sequence number as an extension (sample.000, sample.001, etc.) and the Herdsbak 

directory as the destination.  (In this example, Sample2 is the name of the herd file).  Select OK 

to proceed with the backup, or choose a different destination or file name. 

A backup to the Herdsbak directory on your hard disk protects you from user error or data file 

corruption, but not equipment failure or other disasters.  Always keep a backup on removable 

media and off site. 

BACKING UP YOUR DATA FILES IS VERY IMPORTANT.  Therefore, Cow Sense makes the task easy 

to do.  Get in the habit of backing up your files often; data files become corrupt, hard disks crash, 

lightning strikes.  Disaster happens without warning!  You can back up any of your Cow Sense 

herds at any time by going to Utilities > Back Up Herd from the Cow Sense Main Menu. 

Set Up Function 

This function allows you to decide whether you will be using chute-side devices to aid in your 

data collection.  Although optional, these devices may improve the accuracy and efficiency of 

recording data chute-side.  You may choose to use one or all of these devices, or you may choose 

to manually enter the data into each animal’s 

record.  Both choices can utilize the same powerful 

Auto Sort or Cow COMM Pro features. 

If you choose to use any of these chute-side 

devices, you will need to choose a Serial 

communications (COM) port or RS232 ports on the 

back of your laptop computer (assuming you are 
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Figure 9: EID Settings 

using a laptop computer for chute side data collection) to which these devices can be attached.  

Serial ports are used to interface between the device and your computer (see Figure 8).  For 

many computer peripheral devices the USB interface has replaced the serial port.  As of 2007, 

most modern computers are connected to devices through a USB connection.  If your computer 

does not have COM port(s) you will need some type of an adapter to interface between these 

devices and your computer.  You will then designate in Cow COMM, through a procedure 

described later, which COM port you will be using with which device. 

Chute-Side Devices 

To date, the list of chute-side devices include RFID or EID readers, electronic scales, hip height 

measurement tools, bar code readers, digital thermometers and certain LED signs.  Cow COMM 

allows for real time interface of RFID readers with Cow Sense.  If an animal has an existing 

RFID associated with it’s record in Cow Sense, Cow COMM will recognize and automatically 

“Look-up” (or retrieve) an individual animal’s record once the RFID is read.  Cow COMM also 

allows for automatic real time input of an animal’s weight, RFID, hip height or temperature into 

its Cow Sense record.  The electronic interface with an LED sign provides the capability to 

display the results of an automated sort group. 

Electronic Identification (EID) 

EIDs include electronic tags, boluses, and implants.  EIDs can be useful to track individual cattle 

and retrieve past records or add new data to an animal’s record.  Although these devices are not 

necessary for the use of Cow COMM, they can help you to more efficiently access animal 

records in the program.  From the Cow COMM Main Menu, 

select Set Up > Chute-Side Devices > Electronic 

Identification.  The EID Settings screen will appear. 

If you are using EIDs, select which EID your operation is using 

to identify the cattle from the drop-down list.  IF you are not 

using EIDs, you will select the NOT USED option from the 

drop-down list (see Figure 9). 

Table 1 lists the RFID Readers with which Cow COMM is 

compatible at the time this support document was created.  To 

view a list of our most current Readers go to 

http://www.midwestmicro.com/docs/info/info_cowcomm.pdf 
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Table 1.  Compatible RFID Readers 

• AgInfoLink • I.D.ology Lightning ROD 

• Allflex • Reseaumatique 

• AVID – Bolus • Syscan Live Track 

• AVID – Implant • Tag Tracker 2 

• Destron Pocket Reader • TIRIS 

• Digital Angel (Destron Ferring) • Y-Tex 

• Gallagher BR Series • Y-Tex Panel Reader 

• Gallagher HR3 Series  

You will then choose which COM port on your computer you will use to communicate with the 

RFID reader.  Once you have chosen the port by selecting the radio button to the left of the 

appropriate COM port (1 - 8), select OK.  A Verify Settings message box will appear to verify 

that you have chosen the desired COM port (see Figure 10). 

Figure 10: Verify Settings 

If the settings are correct, select OK.  If they are not correct, select Cancel 

and you will be able to re-set the type of RFID and the COM port.  If you 

select a COM port that is not available for use, a Port Unavailable message 

box will appear informing you to choose another COM port (Figure 11a).  

If you select a COM port that is already being used, a Port In Use message box will appear 

informing you to choose another COM port (Figure 11b). 

Figure 11a: Port Unavailable   Figure 11b: Port In Use 

Scales 

From the Cow COMM Main Menu, select Set Up > Chute-Side Devices > Scales.  The Scale 

Settings screen will appear (see Figure 12). 

Figure 12: Scale Settings 

From the drop-down list, select which type of electronic scale you 

will be using to weigh your cattle.  If you are not weighing your 

cattle at this time or will be entering a weight manually, you will 

select the NOT USED option from the drop-down menu. 
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Figure 13: Verify Settings 

 

Table 2 lists the scales with which Cow COMM is compatible at the time this support document 

was created.  To view a list of our most current scales go to 

http://www.midwestmicro.com/docs/info/info_cowcomm.pdf 

Table 2.  Compatible Scale Indicators 

• Cardinal 205 • Horizon 

• Digi-Star EZ • Reliable 500 

• Digi-Star SDM • Reliable 600 

• Digi-Star SW 4600EID • Tru-Test 700 Series 

• Digi-Star SW 550 • Tru-Test 2000 Series 

• Gallagher 300 • Tru-Test 3000 Series 

• Gallagher 600/700/800 (Ernie) • Weigh-Tronix 

• GSE 350 • Weigh-Tronix 640 

 

Once you have selected your scale indicator, you need to select 

a COM port for which the communication is to be established.  

In the event a COM port is not available you will receive a 

message box as reflected by Figure 11b. 

Only the available COM ports on your computer can be 

selected.  You will receive the message box displayed in 

Figure 13 once a compatible scale and port has been selected. 

Hip Height Measure 

From the Cow COMM Main Menu, select Set Up > Chute-Side Devices > Hip Height 

Measure.  The Hip Height Settings screen will appear (see Figure 14). 

Figure 14: Hip Height Settings 

At this time, the only device listed is the Digitape.  However, since 

this tool was setup in Cow COMM, the manufacturer no longer 

makes this model of the Digitape that can connect to a computer’s 

COM port. 

Should you have a Digitape with a 

serial connection, select Digitape 

from the drop down and select a COM port for which the 

communication is to be established.  In the event a COM port is 

not available you will receive a message box as reflected by 

Figure 11b. 

Only the available COM ports on your computer can be selected.  

You will receive the message box displayed in Figure 15 once a 

compatible device and port has been selected. 

Figure 15: Verify Settings 
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Bar Code Reader 

Figure 16: Bar Code Settings 

At this time, the only device listed is the Symbol.  Once you have 

selected Symbol, you need to select a COM port for which the 

communication is to be established (See Figure 16).  In the event a 

COM port is not available you will 

receive a message box as reflected by 

Figure 11b. 

Only the available COM ports on your computer can be selected.  

You will receive the message box displayed in Figure 17 once a 

compatible device and port has been selected. 

Thermometer and Sign 

The setup process for the Thermometer and Sign are similar to the other devices explained 

earlier in this document.  The Sign is used to display the results of the Auto Sort function on an 

LED sign (see Auto Sort functions page 41).  The Thermometer is used to record time and 

temperature taken for an animal in the Remarks field on the animals record.  Since a limited 

number of our customers use these devices, we will not go into further details, as their 

application is very user specific.  As always for any question on our products don’t hesitate to 

call or email our support department. 

Figure 17: Verify Settings 
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Working Chute-side with Cow COMM. 
Here is where you will learn how to setup Cow COMM for working cattle chute-side or real-

time.  (If you are not using Cow COMM chute-side but wish to use the post-processing 

functions, proceed to page 35-39 of this document).  This capability provides you the ability to 

access previous data as well as add data to animal records.  Figure 18 provides a graphical 

representation of the process of working cattle with Cow COMM. 

 

Figure 18: Processing Cattle Chute-side with Cow COMM 
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Figure 19: Work Settings 

 

Activity Function 

Now that you have chosen the type of devices (if any) you will be using, you are prepared to 

process cattle chute-side with Cow COMM. 

Process… 

In order to process the cattle, from the Cow COMM Main Menu, select Activity > Process….  

Choose which type of animals you want to process.  Select Calves, Cows, or Bulls. 

Calves 

Work Settings Screen 

Before you work your cattle, you will need to define your 

work settings.  A Work Settings screen (Figure 19) will 

appear with a Functions tab, a Settings tab, and an Auto 

Sort Disabled tab (Note: the Auto Sort Disabled tab is 

“grayed out” or not available to you unless the Auto Sort 

function is enabled from the Functions tab). 

Functions Tab 

Tagging 

Choose which tagging option applies to your Herd.  Please 

note that in Cow COMM an animal’s Primary ID refers to its unique animal ID in Cow Sense 

(ex. Cow ID, Bull ID, Calf ID) visual tag, tattoo, freeze brand, etc.  (See Figure 19) 

• Work Cattle with Existing EID.  Use this option to process animals that already have an 

RFID recorded in Cow Sense.  An RFID reader is connected to your computer through a 

previously selected COM port.  This setting is to be used to scan their RFIDs to call up their 

records from the Cow Sense database. 

• Place EID on Tagged Cattle.  Use this option to process animals that have a Primary ID 

recorded in Cow Sense, although they do not have an RFID yet assigned to their Cow Sense 

record.  This setting is to be used to place an RFID on the animals being worked at this time.  

You will use their Primary ID to call up their record from the Cow Sense database.  An RFID 

reader is connected to your computer through a previously selected COM port.  You will then 

scan their RFID onto their record to be stored in Cow Sense. 

• Tag New Cattle.  Use this option to process animals that have no previous records in Cow 

Sense.  This setting is to be used to create new records for them in the Cow Sense database, 

and will assign a unique identification in the animal ID Field to each of these animal’s 

records.  You may assign a new RFID to them as well, however the RFID is optional.  If you 

select Tag New Cattle, the Assign Primary ID? section will be activated.  See Assign 

Primary ID page 15 for more details. 

• No EID.  Use this option to process animals that have a Primary ID, although they do not 

have an RFID.  This setting is to be used to work cattle that do not have an RFID associated 

with their Cow Sense record and you do not intend to add an RFID at this time.  You will 

manually key in their Primary ID to call up their record from the Cow Sense database. 
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Figure 20: Work Settings 

 

Weighing 

Choose if you wish to have the weight automatically recorded on the individual calf’s record, if 

you wish to manually key it in yourself, or if you are not weighing the calves at this time (see 

Figure 19). 

• Capture Weight Automatically – the scale is connected to your computer through a 

previously selected COM port.  Selecting this option enables communications with the 

chosen scale and the recording of the weights through Cow COMM will be automatic.   

• Enter Weight Manually – the scale is not connected to your computer.  Selecting this option 

enables the ability to key in the weights on the animal’s record in Cow COMM. 

• Not Weighing – a scale is not connected to your computer.  Select this option when you are 

not weighing the animals and no weights are to be recorded. 

Enable Auto Sort? 

This section of the Functions tab enables the use of the powerful Auto Sort capability of Cow 

COMM.  As the name implies this capability provides the ability to pre-designate sort criteria 

based upon existing data and data being collected to automatically sort the animals to the criteria.  

There is additional cost for this functionality and license to use this function are sold on a per 

sort basis.  Two hundred sort licenses are included with your initial Cow COMM purchase (note 

upper right side of Figure 19).  The radio buttons allow you to choose whether or not to 

implement the auto sort function for calves.  Note the number of sorts you have remaining in 

your Auto Sort license is displayed here as well.  If you do not want to sort your calves using 

Cow COMM at this time, select No and proceed to either the “Assign Primary ID?” or “Auto 

Mark?”.  If you would like to learn more about this powerful tool see page 41-46 for additional 

direction on use of the Auto Sort capability. 

Assign Primary ID? 

This option is only available when creating new records 

in Cow COMM.  If you choose the Tag New Cattle 

option in the Tagging section, you will be provided an 

option for Cow COMM to automatically (sequentially) 

assign a Primary ID to the next calf record.  If you select 

Yes, after you manually enter the first new Primary ID, 

Cow COMM will automatically assign the next 

sequential number to the next untagged animal it 

encounters.  Select Yes, if you would like to use this Cow 

COMM tool, or No if you do not wish to use it at this 

time. 

Auto Mark? 

When this feature is turned on, changing any data on a record will mark the record so that you 

can query on Marked records later in Cow Sense.  If you do not need to change any data on the 

record but would still like to add the record to the Marked group you need only hit the “Esc” 

button on your keyboard to manually mark the record.  This procedure is the same for Cows and 

Bulls as well. 
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Figure 22: Settings Tab 

 

Figure 21: Clear Marked Calves 

In the event, you already have records marked in your 

herd you will be notified with the window to the left and 

given the option to clear out any previously marked 

records.  This also allows you to keep a running count of 

how many calves have been marked.  You can see this at the bottom in the middle of the working 

window.  You will see how many animal records there are as well as how many records are 

marked (see Figure 24 for an example). 

Settings Tab 

Stage 

This section of the Settings tab, allows you to choose 

which stage in the production cycle applies to the calves 

with which you are working.  Select the radio button to the 

left of the stage that applies to these calves. 

• Weaning 

• Yearling 

Cohort 

This section of the Settings tab allows you to choose which production cycle applies to the calves 

with which you are working.  In Cow Sense, this is referred to as a cohort (birth group or 

production cycle date).  Please note that all the cohort groups available for that Cow Sense Herd 

appear on a drop-down list, which can be accessed by selecting the Hot button  to the right of 

the field.  From the drop-down list, select the production cycle in which these calves were born 

or assigned.  Once you have finished making selections for your Activity you will need to click 

on the “OK” button.  If you are looking up calf records by calf ID, Cow COMM will only look 

for the animal within the cohort you select.  However, if looking up by EID, Cow COMM will 

access all calf records regardless of cohort group. 

Figure 23: Verify Date 

Cow COMM will use the date set by your computer (shown in the open 

field) unless you change it before selecting OK.  Make sure that the date 

shown in the message box is the correct date.  This is extremely important 

as Cow COMM uses the date to make certain calculations.  Select Cancel 

if you would like to return to the Work Settings screen.  After you select 

OK in the Verify Date message box, the Process Calves screen will 

appear.  (See Figure 24) 

Process Calves Screen 

Use the Process Calves screen to add new information to the calf’s record, to change old 

information, or to add new calves to the Cow Sense database.  Note that the calf’s Primary ID 

number is in the upper left-hand corner and either its sort group or weight (depending on whether 

or not the Auto Sort function is activated – see page 41-46), is in the upper right-hand corner of 

the screen. 
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Figure 24: Process Calves 

 

This screen has a Setup tab, an Input 1 tab, 

and an Input 2 tab.  The Input tabs are 

used to display, enter or modify 

information on a calf’s record.  The Setup 

tab is used to set defaults and validations. 

Setup Tab 

This tab is used to create or change default 

settings and validation settings to save 

time and ensure accuracy of data being 

entered.  Some of these validations may 

already be activated when this tab is 

opened.  This is because an associated 

field may have been checked off in the 

Work Settings screen.  For example, in the Tagging section on the Work Settings screen, in the 

case that you chose Work Cattle with Existing EID, the RFID validation will automatically be 

activated.  However, if you chose No EID, the RFID validation will not be activated.   Please 

understand that regardless of whether or not a validation is activated prior to manipulation of the 

Process Calves screen, it can be turned on or off by the user. 

Defaults 

Defaults are only assumed when creating new records.  Defaults are values that Cow COMM 

will enter automatically without user intervention.  This saves you from having to enter repetitive 

information on record after record.  However, you may change the defaults on any record.  That 

is to say, defaults can be overwritten.  The default settings will then be re-set to values from the 

current record. 

If you are working calves that are all new (i.e. they don’t already exist in Cow Sense), click the 

red New button on the Process Calves screen.  You will then complete the information for the 

first animal on the Input 1 and Input 2 tabs.  Then return to the Setup tab to set the fields where 

you wish the information entered to become a default field.  If you would like a certain field to 

be a default field (i.e. you do not want to have to re-enter the information on all succeeding new 

records), activate the default by clicking on the box next to the name of the field.  Then resume 

working the balance of the cattle and the fields you choose to be defaults will automatically be 

completed for you.  These fields are discussed in the following section. 

Calf or Yearling Group 1 

In this section, the title of your user-defined calf or yearling group 1 will appear (e.g. calf group 

titles are Pasture and Owner in the Sample Herd).  Calf or yearling group 1 contains sub-group 

titles you established in the Define Groups option of the Enter Data drop-down menu in Cow 

Sense.  Select this box if you would like the sub-group on the current record to be a default 

setting. 

Calf or Yearling Group 2 

Same explanation as Calf or Yearling Group 1. 
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Breed 

Select this box if you want to set the breed of the calves as a default. 

Sex 

Select this box if you want to set the sex of the calves as a default. 

Poll 

Select this box if you want to set the horn status of the calves as a default. 

Prefix 

Select this box is you want to set the bangs number prefix as a default. 

Born As 

Select this box if you want to set the status of the calves when they were born (e.g. single, triplet, 

embryo transfer, etc.) as a default. 

Raised As 

Select this box if you want to set the status of the calves as they were raised (e.g. single on foster 

dam, twin on own dam, etc.) as a default. 

Bangs No 

Select this box if you want the bangs number to automatically increase by one sequential number 

on each new calf you process. 

Validation 

Validations are used to warn you if some information is missing or is inappropriate for a 

particular field.  A warning message box will appear if this is the case, however it will not 

prevent you from moving on and saving the record.  This function is used as a “check,” to make 

sure you have entered all of the information you intend to enter during this session. 

If you would like to be warned when information in a field is missing, select the box next to the 

name of the field.  For the Weight and Hip Height fields, there is an additional validation feature.  

You can enter in a range of values into which all of the animals to be processed should fall.  If a 

value is entered on a record that is not within this range, a warning message box will appear.  

Again, you will not be prevented from moving on and saving the record, but you will have to 

acknowledge that this measurement is correct. 

Weight 

Select this box to warn you if the weight field on the calf’s record is not completed.  Also, type 

in the upper and lower end of the range of weights that are acceptable to you.  You will then be 

warned if an entered weight is outside this range. 
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Hip Height 

Select this box to warn you if the hip height field on the calf’s record is not completed.  Also, 

you may type in the upper and lower ends of the range of acceptable hip heights that are 

expected.  You will then be warned if an entered hip height is outside this range. 

Tag 

Select this box to warn you if the ear tag number (Calf ID) field is blank. 

EID 

Select this box to warn you if the RFID number field is blank.  This would generally be used 

only when applying RFIDs to animals. 

Bangs Tag 

Select this box to warn you if the bangs tag number field is blank.  This would generally be used 

only when applying Bangs Tags to animals. 

Calf or Yearling Group 1 

In this section, the title of your user-defined calf or yearling group 1 will appear (e.g. calf group 

titles are Pasture and Owner in the Sample Herd).  Calf or yearling group 1 contains sub-group 

titles you established in the Define Groups option of the Enter Data drop-down menu in Cow 

Sense.  Select this box to warn you if a calf or yearling group 1 sub-group field is blank. 

Calf or Yearling Group 2 

Same explanation as Calf or Yearling Group 1, above. 

Pelvis 

Select this box to warn you if the pelvis area field is blank.  This would generally be used only 

when recording pelvic measurements to animal records. 

Scrotum 

Select this box to warn you if the scrotal circumference field is not completed.  This would 

generally be used only when recording scrotal measurements to bull calf records. 

Breed 

Select this box to warn you if the breed field is not completed. 

Hip Height Option 

Weaning or Yearling 

When collecting Hip Height data you must select if it was taken at weaning time or yearling 

time.  That way when the data goes into Cow Sense it will go to the appropriate field. 
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Input 1 Tab 

The Input 1 and 2 tabs are where you can 

enter, or reference previously entered 

information about each calf (see Figure 25).  

The screen is arranged to provide ease of use 

in data entry and navigation. 

Screen Display 

Note if the Auto Sort function is not activated 

(see Figure 25), the weight of the animal will 

appear in the upper right-hand part of the 

screen (to the right of the tag number). 

The Command Buttons  

The command buttons are located in the lower right of the Input 1 screen. 

Using the command buttons: 

A. Save - If you select this button, Cow COMM will 

save the current record and update the Cow Sense 

database immediately.  Selecting the Save button is 

not required to store the information on the current 

record.  Cow COMM will automatically save the 

added information when you move off the record.  

Clicking on the “Save” button makes it become the 

default and enables the Enter Key on your 

keyboard.  On subsequent animal records you can 

simply touch the Enter Key on your keyboard to 

repeat the Save function. 

B. Print EID this button provides the user the 

capability to print a label with the animal EID, 

visual EID and date.  This is particularly useful 

when collecting samples from animals with EIDs.  This feature is only available in Cow COMM Pro. 

C. New – this button creates a new record.  Clicking on the “New” button makes it become the default and enables 

the Enter Key on your keyboard.  On subsequent animal records you can simply touch the Enter Key on your 

keyboard to repeat the New function. 

D. Cancel – this button clears an unsaved entry. 

E. Delete – this button deletes a current record. 

F. Last – this button takes you back to the last record viewed. 

The Navigation Tool Bar 

All of the Process Calves data entry screens have a navigation tool bar to easily move through 

the data file.  Visualize each data entry screen, which represents a record in your herd database, 

as a single card in a card file.  You may wish to move to the first or last card in the file, or leaf 

forward or back through the file.  The navigation tool bar performs these functions for you on the 

data entry screens.  Note the animal’s primary ID is located in the center of the tool bar.  The use 

of these buttons for navigating between records is noted below. 

Using the navigation tool bar: 

A. This button takes you to the first record in the file. 

B. This button takes you back one record. 

C. This button takes you forward one record. 

Figure 26: The Command Buttons 

 

 

  A.   B. 

  C.    D.    E.    F. 

Figure 27: Navigation Tool Bar 

 

  A.   B.   C.   D. 

Figure 25: Input 1 Tab (Note Auto: Sort inactivated) 



Cow COMM Version 3   

 

21

D. This button takes you to the last record in the file. 

Marked 

The “Marked” box allows you to manually mark a record by selecting or clicking this box.  This 

allows you to flag a particular record for later reference.  If the Auto Mark feature is turned on 

when first setting up the functions in Cow COMM (see Figure 20), changing any data on a 

record will mark the record so that you can query on Marked records later in Cow Sense.  If you 

do not need to change any data on the record but would still like to add the record to the Marked 

group you need only hit the “Esc” button on your keyboard to manually mark the record.  This 

procedure is the same for Cows and Bulls as well. 

Data Entry/Edit Fields 

Find 

This field is for typing in a Visual ID to look up an animals record.  You click in the box, type in 

the Visual ID of the animal you are looking for and then click on the “Find” button to move to 

that animals record.  You must type the ID exactly as it is stored in Cow Sense for this function 

to work properly.  .  Clicking on the “Find” button makes it become the default and enables the 

Enter Key on your keyboard.  On subsequent animal records you can simply touch the Enter Key 

on your keyboard to repeat the Find function.  Hint – be careful of spaces in animal IDs. 

Tag 

This is where the unique Primary ID is entered.  It can be used to locate the record in the Cow 

Sense database.  If this is a new calf, it must be assigned a Primary ID. 

Supp ID 

This field can be used to record a supplemental or backup ID.  For example if you are retagging 

animals you may want to put in the old Visual ID here. 

EID 

This is where the RFID number is entered, either manually or electronically through use of an 

RFID reader that is connected to your computer’s COM port, as previously described.  While 

this 15-digit number can be entered manually, it is not recommended!  Due to the length of the 

number, the chance of a data entry error is increased significantly. 

Weight 

This is where the calf’s weight is entered, either manually or electronically through use of an 

electronic scale that is connected to your computer’s COM port, as previously described. 

Hip Height 

This is where the calf’s hip height is entered either manually or electronically through use of an 

electronic measurement device that is connected to your computer’s COM port as previously 

described. 
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Scrotum 

This is where the calf’s actual scrotal circumference is recorded.  This field is only applicable to 

bull calves. 

Color 

This is where the calf’s color is entered.  It is important for you to be uniform when entering 

information in this field.  For example BLK and Black are recorded as two different colors and 

will be recorded as such in the Cow Sense database. 

Bangs 

This is where the calf’s bangs tag number is entered.  The field is divided into two parts.  The 

first is for the prefix and the second is for the sequential number. 

Muscle Score 

This is where a muscle score is entered. 

Birth Date, Sire and Dam 

These fields are for reference only.  They cannot be edited here. 

Calf or Yearling Group 1 

In this section, the title of your user-defined calf or yearling group 1 will appear (e.g. calf groups 

titles are Pasture and Owner in the Sample Herd).  Calf or yearling group 1 contains sub-group 

titles you established in the Define Groups option of the Enter Data drop-down menu in Cow 

Sense.  Click on the Hot button  at the right side of this field to choose which sub-group to 

which this calf belongs. 

Calf or Yearling Group 2 

Same explanation as Calf or Yearling Group 1, above. 

Breed 

This is where the calf’s breed is entered. 

Sex 

This is where the calf’s sex is recorded.  Select the Hot button  at the right of the field for 

choices.  A valid entry in this field is required for saving and storing a calf record in Cow Sense. 

Poll 

This is where the calf’s horn status is recorded.  Select the Hot button  at the right of the field 

for choices.  (Not a required field.) 

Remarks 

This is where any additional notes to the calf’s record are entered. 
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Input 2 Tab 

The Input 2 tab (see Figure 28) is where you can enter 

more information about each calf, or confirm 

previously entered data. 

Born As 

This is where you record the status of the calf when it 

was born (e.g. single, triplet, embryo transfer, etc.).  

Select the Hot button  at the right of the field for 

choices.  A valid entry in this field is required for 

saving and storing a calf record in Cow Sense.  See 

Cow Sense User’s Guide for additional information and 

definition of these codes. 

Raised As 

This is where you record the status of the calf as it was raised (e.g. single on foster dam, twin on 

own dam, etc.).  Select the Hot button  at the right of the field for choices.  A valid entry in 

this field is required for saving and storing a calf record in Cow Sense. See Cow Sense User’s 

Guide for additional information and definition of these codes. 

New ID 

This field is for entering the New ID for a calf that will become a replacement cow or bull. 

DNA Case 

This field is for entering the bar code number as may be used when collecting a tissue sample for 

DNA.  If collecting a DNA sample it is recommended that you enter the number from the 

collector into this field for future reference.  This may be manually entered or electronically 

through the use of a barcode reader that is connected to your computer’s COM port as previously 

described. 

Pelvis V 

This is where the calf’s vertical pelvic measurement is recorded (in cm.). 

Pelvis H 

This is where the calf’s horizontal pelvic measurement is recorded (in cm.). 

Pelvis A 

This is where the calf’s pelvic area is displayed.  As long as the vertical and horizontal pelvic 

measurements are recorded, the pelvic area is calculated in square centimeters and automatically 

displayed in this field. 

Figure 28: Input 2 Tab 
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Adj Pelvis 

This is where the adjusted pelvic area is displayed.  It is computed by Cow COMM using either 

of 2 methods – Area or Est. BW (estimated maximum birth weight).  Whichever option is chosen 

is stored in the Adjusted Pelvic Measure field on the Cow Sense calf record. 

Off – Select Off if you do not want Cow COMM to calculate an adjusted pelvic area at 

this time. 

Area – Select Area if you want Cow COMM to calculate an adjusted pelvic area (in 

square centimeters) according to the age of the calf. 

Est. BW – Select Est. BW if you want Cow COMM to calculate the estimated maximum 

birth weight of a calf that this potential cow should be able to have without assistance.  

The source of this calculation is from the document Pelvic Measurements for Reducing 

Calving Difficulty, NebGuide G87-839-A, Gene H. Deutscher, Extension Beef Specialist. 

Ultrasound Measures 

Back fat – This is where you will record the actual ultrasound measurement taken for 

back fat. 

IMF – This is where you will record the actual ultrasound measurement taken for inner 

muscular fat. 

REA – This is where you will record the actual ultrasound measures taken for rib eye 

area. 

Summary 

The summary box displays the ADG (Average Daily Gain) Last Wt, ADG Wng or Yrlg, WDA 

(Weight per Day of Age) and Frame Score. 

Audible Cues 

Audible tones are available to verbally confirm the sex of the calf if present on the animal record.  

In addition as EID and weight are entered a verbal confirmation will acknowledge that they have 

been recorded.  If you wish to use this function check the volume settings on your computer to 

ensure it is turned on and set at a level loud enough to hear.  Some users have attached additional 

speakers to the computer to increase the volume. 

Cows and Bulls 

Processing cows and bulls with Cow COMM is very similar, so they will be described 

simultaneously in this document.  If there are any differences between the two sections, they will 

be mentioned at that time. 
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Work Settings Screen 

From the Cow COMM main menu, select Activity > Process > Cows (or Bulls) A Work 

Settings screen will appear with a Functions tab and an Auto Sort Disabled tab (see Figure 29). 

A tab on a screen in Cow COMM is much like a tab in a card file.  It allows you to direct focus 

to the card you would like to look at and allows you to flip back and forth between cards. 

Functions Tab 

Tagging 

Choose which tagging option applies to your Herd.  

Please note that in Cow COMM an animal’s 

Primary ID refers to its unique animal ID in Cow 

Sense (ex. Cow ID, Bull ID, Calf ID) visual tag, 

tattoo, freeze brand, etc. 

• Work Cattle with Existing EID.  Use this 

option to process animals that already have an 

RFID recorded in Cow Sense.  An RFID reader 

is connected to your computer through a 

previously selected COM port.  This setting is 

to be used to scan their RFIDs to call up their 

records from the Cow Sense database. 

• Place EID on Tagged Cattle.  Use this option 

to process animals that have a Primary ID 

recorded in Cow Sense, although they do not 

have an RFID yet assigned to their Cow Sense record.  This setting is to be used to place an 

RFID on the animals being worked at this time.  You will use their Primary ID to call up 

their record from the Cow Sense database.  An RFID reader is connected to your computer 

through a previously selected COM port.  You will then scan their RFID onto their record to 

be stored in Cow Sense. 

• Tag New Cattle.  Use this option to process animals that have no previous records in Cow 

Sense.  This setting is to be used to create new records for them in the Cow Sense database, 

and will assign a unique identification in the animal ID Field to each of these animal’s 

records.  You may assign a new RFID to them as well, however the RFID is optional.  If you 

select Tag New Cattle, the Assign Primary ID? section will be activated.  See Assign 

Primary ID page 17 for more details. 

• No EID.  Use this option to process animals that have a Primary ID, although they do not 

have an RFID.  This setting is to be used to work cattle that do not have an RFID associated 

with their Cow Sense record and you do not intend to add an RFID at this time.  You will 

manually key in their Primary ID to call up their record from the Cow Sense database. 

Weighing 

Choose if you wish to have the weight automatically recorded on the individual cow’s (or bull’s) 

record, if you wish to manually key it in yourself, or if you are not weighing the cows (or bulls) 

at this time. 

Figure 29: Work Settings 



Cow COMM Version 3   

 

26

• Capture Weight Automatically – Choose this option if the scale is connected to your 

computer through a previously selected COM port and the recording of the weights will be 

automatic.  Selecting this option enables communications with the chosen scale. 

• Enter Weight Manually – the scale is not connected to your computer.  Choose this option 

to manually key in the weights on the animals’ records. 

• Not Weighing – Choose this option if you are not weighing the animals at this time and no 

weights will be recorded. 

Enable Auto Sort? 

This function is not presently available for cow (or bull) records and therefore cannot be 

selected.  It is currently being developed, at which time this function will be enabled and 

available for use. 

Assign Primary ID? 

This feature has application when you are creating new cow or bull records with Cow COMM 

and attaching sequentially numbered tags on them.  If you choose the Tag New Cattle option in 

the Tagging section, you are presented an option if you would like Cow COMM to automatically 

assign a Primary ID to the next cow (or bull) record.  If you select Yes, manually enter the first 

new Primary ID.  Cow COMM will then automatically assign the next sequential number to the 

next animal record entered.  Select Yes, if you would like to use this or No if you intend to 

manually key in the animal ID. 

Auto Mark? 

When this feature is turned on, changing any data on an animals’ record will mark the record so 

that you can query on Marked records at a later time.  If you do not need to change any data on 

the record but would still like to add the record to the Marked group you need only hit the “Esc” 

button on your keyboard to manually mark the record.  This is the same for Calves as well. 

In the event, you already have records marked in your 

herd you will be notified with the message displayed in 

Figure 30 and given the option to clear out any 

previously marked records.  This also allows you to 

keep a running count of how many cows or bulls have 

been marked.  You can see this at the bottom right of 

the working window.  You will see how many animal 

records there are as well as how many records are 

marked.  See Figures 33a and 33b. 

Auto Sort Disabled Tab 

The Auto Sort function is not yet available for cow or bull records and is therefore “locked” so 

that you cannot use it at this time. 

After you select OK on the Verify Work Settings message box, the Enter Cows (or Bulls) screen 

will appear. 

Figure 30: Clear Marked Cows 
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Figure 31: Verify Work Settings 

 
 

When you have completed filling out the Functions tab, 

select OK and a Verify Work Settings message box 

will appear (see Figure 31). 

Verify Work Settings 

If the settings are correct, select OK.  If they are not 

correct, select Cancel, make any necessary corrections, 

and then repeat the verification step. 

Verify Date 

After verifying your settings a “Verify Date” screen will appear.  Confirm the date by selecting 

the “OK” button.  Select the “Cancel” button to modify the date. 

Figure 32:  Verify Dates 

Cow COMM will use the date set by your computer (shown in the 

open field) unless you change it before selecting OK.  Make sure that 

the date shown in the message box is the correct date.  This is 

extremely important as Cow COMM uses the date to make certain 

calculations.  Select Cancel if you would like to return to the Work 

Settings screen.  After you select OK in the Verify Date message 

box, the Process Calves screen will appear. 

Process Cows (or Bulls) Screen 

Figures 33a & 33b show the processing screens for cows and bulls. Use these screens to add new 

information to an existing cow (or bull) record, to change old information, or to add new cow (or 

bull) records to the Cow Sense database.  Note that the cow’s (or bull’s) Primary ID number is 

also displayed in bold font in the lower left-hand corner and the cow’s (or bull’s) weight (if 

previously recorded) is in the lower right-hand corner of the screen.  Note in this case Cow 

COMM is in “Edit” mode (lower most left) indicating that you are ready to add data to existing 

animal records. 

Figure 33a: Process Cows     Figure 33b: Process Bulls 
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Figure 34: The Navigation Tool Bar 
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Figure 35: Command Buttons 

 

 

 

Special Enter Data Features 

The Navigation Tool Bar 

All of the Process Cows (or Bulls) data screens have a navigation tool bar to easily move through 

the data file.  Visualize each data entry screen, which represents a record in your herd database, 

as a single card in a card file.  You may wish to move to the first or last card in the file, or leaf 

forward or back through the file.  You might also want to mark a card and come back to it after 

further browsing.  The navigation tool bar performs these functions for you on the data entry 

screens. 

Using the navigation tool bar: 

A. This button takes you to the first record in the file. 

B. This button takes you back 20 records. 

C. This button takes you back one record. 

D. This button marks a record so you can return to it with button E. 

E. This button takes you to the record you marked with button D. 

F. This button takes you forward one record. 

G. This button takes you forward 20 records. 

H. This button takes you to the last record in the file. 

Command Buttons 

All Process Cows (or Bulls) data screens have command buttons that allow you to manipulate 

records in the data file.  You may save a record, clear unsaved entries, create a new record, find 

an existing record, delete a record, or return to the last record processed.  Cow Sense is a very 

safe program, in that it does not permit you to leave a record without saving changes, even if you 

do not intentionally click the Save button.  In addition, each time a record is saved it is actually 

written to the hard disk.  This way, you do not have to worry about losing data through 

forgetfulness or due to a power failure.  At most, you will only lose information on the current 

unsaved record. 

Using command buttons: 

A. This button saves the current record. 

B. This button creates a new record. 

C. This button opens a dialog box to find an animal ID. 

D. This button reverses any changes made to the current 

record. 

E. This button deletes the current record. 

F. This button will return you to the last animal record 

processed 

G. This button is available to print an EID label using 

Cow COMM Pro upgrade functions. 

Clicking on the “Save”, “New” or “Find” buttons 

makes them become the default and enables the Enter Key on your keyboard.  On subsequent 

animal records you can simply touch the Enter Key on your keyboard to repeat the “Save”, 

“New” or “Find” functions.  Hint – be careful of spaces in animal IDs 

Ordering Features 

Sort by ID – check this box if you want to put your cow (or bull) records in order of Primary IDs.  

If this is unchecked, the animal records will be displayed in the order in which they were initially 

added to Cow Sense. 

  A.   C. 

  D. 

  B. 

  E.   F.   G. 
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Figure 36: Marked Box 

 

Marked Feature 

The “Marked” box (see Figure 36) 

allows you to manually mark a record by 

selecting or clicking this box.  This 

allows you to flag a particular record for 

later reference.  If the Auto Mark feature 

is turned on when first setting up the 

functions in Cow COMM (see page 15), 

changing any data on a record will mark 

the record so that you can query on 

Marked records later in Cow Sense.  If 

you do not need to change any data on 

the record but would still like to add the 

record to the Marked group you need 

only hit the “Esc” button on your 

keyboard to manually mark the record. 

Fields on Process Cows (or Bulls) Screen 

Unlike calves, there is only one input screen for use in Processing Cows and Bulls.  The only 

required fields for entry of records on this screen are the Cow (or Bulls) ID, Cow Birth Date, 

Status and Bull Type fields.  If data is not recorded in these fields, a validation message will 

appear, prompting you to complete the required missing data. 

Cow (or Bulls) ID  

This is the cow’s (or bull’s) unique Primary ID.  It can be used to locate the record in the Cow 

Sense database.  If this is a new cow (or bull), she (or he) must be assigned a Primary ID.  A 

valid entry in this field is required for saving and storing a cow or bull record in Cow Sense. 

Bangs Tag 

This field is used to record the cow’s (or bull’s) bangs tag number.  The field is divided into two 

parts.  The first is for the prefix and the second is for the sequential number.  The prefix is a 

default and if you are adding new cows (or bulls) to your herd, it will carry over to the next new 

cow (or bull) record.  However, to set the default, you must select the “Save” button before 

adding a new record. 

Tattoo 

This field is used to record an animal’s tattoo.  This information will be stored in the Tattoo field 

(which is by default the LE tattoo) in Cow Sense. 

Registration 

This is the number assigned by the Breed Association when the animal was registered.  This field 

is only functional in the Purebred Mode. 
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EID 

This field is used to record an RFID number.  It can be entered either manually or automatically 

by a connection of the RFID reader to your computer via a COM port, as previously described.  

(It is highly recommended that you do not key RFID numbers into Cow COMM as such long 

numbers are highly prone to contribute to data entry errors.) 

Supp. ID 

This field can be used to record a supplemental or backup ID. 

DNA Case Number 

In the event that you are collecting DNA samples, this field can be used to record the sample ID 

number that is often affixed to the collection device.  If the sample collector was purchased from 

Cow Sense Genetic Services, it will also have a bar code incorporated with the ID number.  This 

Bar code can be scanned with a Bar Code Reader (connected to your computer’s Com port as 

previously described) and it will be automatically recorded in this field. 

Birth Date 

This is the cow’s (or bull’s) date of birth.  A valid entry in this field is required for saving and 

storing a cow record in Cow Sense.  It is not a required field for creating a bull record.  This is a 

default field and if you are adding new cows (or bulls) to your herd, it will carry over to the next 

new cow (or bull) record.  However, to set the default, you must select the “Save” button before 

adding a new record. 

Origin 

This is the source of the cow (or bull).  It can be a ranch name, a person’s name, the IDs of this 

cow’s (or bull’s) parents if they are part of your Cow Sense herd, etc.  This is a default field and 

if you are adding new cows (or bulls) to your herd, it will carry over to the next new cow (or 

bull) record.  However, to set the default, you must select the “Save” button before adding a new 

record. 

Cow (or Bull) Group 1 

This field is user defined.  It contains sub-group titles you established in the Define Groups 

option of the Enter Data drop-down menu in Cow Sense.  You are limited to the selections you 

defined.  You can click on the Hot button  at the right of the field to choose from your 

previously defined sub-groups.  This is a default field and if you are adding new cows (or bulls) 

to your herd, it will carry over to the next new cow (or bull) record.  However, to set the default, 

you must select the “Save” button before adding a new record. 

Cow (or Bull) Group 2 

Same explanation as Cow (or Bull) Group 1, above. 

Breed 

This field is used to record the breed of the animal.  Select the Hot button  at the right of the 

field to choose from the breeds you have listed in Breeds tab of the Define Groups option of the 
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Enter Data drop-down menu in Cow Sense.  You are limited to the selections you have included 

in your database.  This is a default field and if you are adding new cows (or bulls) to your herd, it 

will carry over to the next new cow (or bull) record.  However, to set the default, you must select 

the “Save” button before adding a new record. 

AI Bull (cows only) 

This field is only on Cow records and is used to record the AI Sire that was used, if applicable.  

Select the Hot button  at the right of the field to choose from the active AI Sires you have 

recorded in Cow Sense. 

Planned Sire (cows only) 

This field is only on cow records and is populated when a Planned Sire is entered on the Cow’s 

Record in Cow Sense (in the Supplemental Data Entry area) or by Cow Sense Power Tools.  This 

is to assist when AI breeding is utilized.  When working chute side the AI technician will know 

which bull any given cow is to be bred to by checking this field.  That way the decision of which 

bull a cow is to be bred to can be made in advance and relayed to the person actually performing 

the AI. 

AI Technician (cows only) 

This field is only on cow records and used to record the person who performs the AI. 

AI Date (cows only) 

This field is only on Cow records and is used to record the date that the cow was artificially 

inseminated.  If the AI Bull was selected during this session the AI Date will be automatically 

recorded as the date you confirmed while defining Work Settings previously. 

Preg Date (cows only) 

This field is only on cow records and populated if a Preg Status (Bred or Open ) is selected.  

Cow COMM will automatically default the Preg Date to the date you had confirmed while 

defining Work Settings previously.  If you would like to type in a different date on a succeeding 

record, you can override the Insert Preg Date default. 

If you enter an AI Breeding event in to the Breeding Table of Cow Sense, when recording Days 

Bred and a Date, you will receive notification if the pregnancy is a likely result of that AI 

Breeding.  You will also see the Technician who preformed the AI if it was entered on the 

Breeding record. 

Preg Status (cows only) 

This field is only on cow records and used to record if the cow was Bred or Open at the time of 

pregnancy exam.  Just click next to the appropriate results for each cow. 

Days (cows only) 

This field is only on cow records and used to record the number of days a cow is bred.  Should 

the technician performing the procedure call days bred, at the time of the pregnancy examination, 

enter the number called. 
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Status 

This field defines whether the cow (or bull) is “active” or “gone” in your herd.  A valid entry in 

this field is required for saving and storing a cow or bull record in Cow Sense.  Click the Hot 

button  at the right of the field to choose the status of the cow (or bull).  This is a default field 

and if you are adding new cows (or bulls) to your herd, it will carry over to the next new cow (or 

bull) record.  However, to set the default, you must select the “Save” button before adding a new 

record. 

Type (bulls only) 

This field is for selecting the type of service for which a bull will be used within a herd.  This is a 

required field for bulls and either AI, Both or Herd must be selected.  AI means that this bull is 

only used in AI Breeding.  Both means that the bull is used for AI as well as for Natural Service 

mating.  Herd means that this bull is only used for Natural Service matings. 

Poll 

This field is used to record the horn status of the cow (or bull).  Click on the Hot button  at the 

right of the field for choices. 

Weight 

This field is used to record the cow’s (or bull’s) weight.  It can be entered either manually or 

automatically by a connection of an electronic scale to your computer via a COM port, as 

previously described. 

Scrotum (bulls only) 

This field is used to record the scrotal circumference of the bull and only applies to the bull 

records.  It is a numeric field only. 

Hip Height 

This field is where a cow or bulls hip height measurement would be entered.  This plays a part in 

the calculation of the frame score for a cow or bull. 

Pelvis 

This field is used to record the cow’s (or bull’s) pelvic measurement.  This is a numeric field 

only. 

Condition (cows only) 

This field is used to record the cow’s (or bull’s) body condition score. (BCS).  This is a default 

field and if you are adding new cows (or bulls) to your herd, it will carry over to the next new 

cow (or bull) record.  However, to set the default, you must select the “Save” button before 

adding a new record.  

Mouth (cows only) 

This field is used to record the condition of the cow’s teeth and only applies to the cow records.  

This is a default field and if you are adding new cows to your herd, it will carry over to the next 
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new cow record.  However, to set the default, you must select the “Save” button before adding a 

new record. 

Udder Score  (cows only) 

In this field you would enter the udder score for cows.  See document in Cow Sense Help > 

Reference for further details on the Beef Improvement Federation recommended scoring system. 

Date Acquired 

This field is used to record the date you place the cow (or bull) in your herd.  This is a default 

field and if you are adding new cows (or bulls) to your herd, it will carry over to the next new 

cow (or bull) record. 

Cost 

This field is used to record a purchase cost for the cow (or bull) if you purchased her (or him). 

Last Calf (cow only and for display only) 

This field displays the birth date for the cow’s last calf. 

MPPA (cow only and for display only) 

MPPA stands for Most Probable Producing Ability.  This field displays this performance ratio.  

See the Cow Sense User’s Guide for more information on this measure. 

Avg Interval (cow only and for display only) 

This field displays the average number of days between calving dates for a cow. 

Pct Body Wt Wnd  (cow only and for display only) 

This field displays Percent Body Weight Weaned.  This measurement takes into account how 

many pounds that a cow has weaned as a percentage of her own weight. 

Avg. Wean Wt (cow only and for display only) 

This field displays average weaning weight of all calves for a cow that have a weaning weight 

recorded. 

Avg. Yrlg Wt  (cow only and for display only) 

This field displays average yearling weight of all calves for a cow that have a yearling weight 

recorded. 

Frame Score (display only) 

This field shows the frame score of the animal being displayed. 
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Figure 37:Post-processing functions in Cow COMM 

Remarks 

This field is used to make any additional notes about the cow (or bull).  At the bottom of the 

processing bulls and processing cow screens, you will see in larger font the visual ID of each 

animal as well as the last weight that was taken for them.  Note if you are using the Auto Mark 

Feature, the number of the marked records appear in the lower right hand corner of this screen as 

well. 

Audible Cues 

Audible tones are available to verbally confirm the addition of EID and weight.  As this 

information is entered a verbal confirmation will acknowledge that they have been recorded.  If 

you wish to use this function check the volume settings on your computer to ensure it is turned 

on and set at a level loud enough to be heard.  Some users have attached additional speakers to 

the computer to increase the volume. 

Post-Processing use of Cow COMM  

As mentioned in the introduction 

of this document, Cow COMM 

can also be very useful for user’s 

through a post-processing interaction 

to retrieve data collected in scale 

indicators or RFID readers and 

automatically update data in Cow 

Sense.  This function allows you to 

capture data in these electronic 

devices in the field and afterward 

return to your computer and upload 

into Cow Sense to update or in some 

case even create new animal records.  

The following sections describe how 

Cow COMM can help you bring data 

in from a scale indicator or RFID 

Reader.  Figure 37 relates the 

process of using Cow COMM in this 

manner. 
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Retrieve Scale Data 

Of the scale indicators mentioned earlier in this document, some have the ability to not only 

work chute side but can also be used as a data collection device themselves.  In those cases the 

data can be retrieved via Cow COMM and used to update or even add new records to your Cow 

Sense herd file.  You will need to set up your devices (scale indicators, RFID readers, etc) with 

your computer and Cow COMM as indicated on pages 10 – 11 of this User’s Guide.  Also 

consider how you want the information to be updated into Cow Sense before processing the 

cattle.  This will help to improve your accuracy in importing the information correctly. 

Some scale indicators, other than the ones listed below have the ability to export weight data 

through their own software.  You would want to check with the User’s Guide or representative 

from any other scale companies to see if and how they can export or dump out data from their 

scale indicators.  In those cases the data can be imported into Cow Sense using the Import Tool 

(included with Cow Sense).  For further documentation on the Import Tool see page 188 of your 

Cow Sense User’s Guide or go into the Import Tool (Utilities > Transfer Data > Import > 

Import Tool.  Click the Help Button for further documentation.) 

This section will discuss an automated function of Cow COMM to retrieve data collected in 

certain scale indicators bypassing the use of the Import Tool.  The initial setup process to retrieve 

and import scale data with Cow COMM is common for all scales.  These steps are outlined 

below. 

1. To “Retrieve” scale data from the indicators set up the connection between 

Cow COMM and the indicator as described earlier on pages 10-11. 

2. Connect the indicator to your computer with the cable that would have been 

shipped with your indicator or contact your supplier who sold you the scale. 

3. Turn on the scale 

4. From the Cow COMM Main Menu select Activity > Retrieve Scale Data. 

Digi-Star SDM & SW 550 

AND 

Tru-Test 700, 2000 & 3000 

Working with these scales Cow COMM can automatically retrieve scale weights and link them 

to existing records in Cow Sense by matching on the animal’s primary ID or EID.  If the EID is 

recorded in the scale indicator and not yet in Cow Sense it too can be added through this 

function.  Hint – if matching to the Primary ID it must be the same in Cow Sense as it is recorded 

in the scale indicator.  Print out a list of ID’s from Cow Sense for reference in the field. 

The process to retrieve and import scale data with Cow COMM is identical for the scales listed 

above.  These steps are outlined below. 

1. Upon launching the command data as described above, the Retrieve Scale 

Data window (Figure 38) will appear. 

2. Select which “Scale File:” you wish to retrieve by clicking on the Hot button 

 at the right of the field from the drop down , then click the “Retrieve” 

Button.  You will see the data being brought in from the scale head as the 

“Reading” box counts how many records are being retrieved. 
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3. Once the data is retrieved, you will want to select the Target records (Calves, 

Cows or Bulls) that you intend to update.   

4. Then select what ID you will be Matching to, either Primary or Electronic. 

5. If your Targets are the calves, you will need to select the Stage and the Cohort 

date. 

6. If your targets are Cows and Bulls, you will need to decide whether or not to 

“Overwrite” the existing weight. 

 

Tru-Test has created a 

field for what they call 

a Life Time ID or LID.  

This field is optional 

and does not need to be 

populated or imported.  

However if used, Cow 

COMM provides you a 

choice of where you 

wish to store this data in 

Cow Sense, either in the 

Supplemental ID or the 

DNA case number 

fields.   

Now that you have selected what you want to import and where, you can click on the “Import” 

button.  You will see the import of data progress and at the end of the import, you will have the 

opportunity to view the import log.  If there were any issues with the import, such as “could not 

match the ID,” the log will inform you.  You should always review the log for anything that 

needs to be resolved and entered manually. 

Horizon 

You will need to make sure that you install the software that came with your Horizon Scale as 

previous to using this function.  From the Cow COMM Main Menu select Activity > Retrieve 

Scale Data.  A Retrieve Scale Data window will appear (see Figure 39).  There are two functions 

to this interface. 

Figure 39 Horizon Retrieve Scale Data via Cow COMM 

Retrieve – Retrieve data from your scale using the 

Horizon Browser by clicking this button.  Retrieve only 

one (1) file at a time and then proceed to the import 

below.  If you have already retrieved data from your scale 

using the Horizon Browser, skip this step and go to the 

Import. 

Import – Click the “Import” button to import scale data.  

A screen will appear where you have to choose to import Bulls, Cows or Calves.  Select the 

correct target (animal type) based on what data you retrieved from your scale.  After you 

 

 

Figure 38 Digi Star and Tru-Test Retrieve Scale Data via Cow COMM 
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successfully import all data from that file, you can “Exit” out.  Repeat the process to “Retrieve” 

and “Import” any other files. 

Reliable 600 

You will need to make sure that you install the software that came with your Reliable Scale 

previous to using this function.  From the Cow COMM Main Menu select Activity > Retrieve 

Scale Data.  A Retrieve Scale Data window will appear (see Figure 40). 

Figure 40 Retrieve Reliable Scale Data via Cow COMM 

Retrieve – Retrieve data from your scale using Cattle-

Logger by clicking the button to the left.  Retrieve only one 

(1) set of data (bulls, cows or calves), and then proceed to 

the import function.  If you have already retrieved data 

from your scale using Cattle-Logger, skip this step and go 

to “Import”. 

Import – Click the “Import” button to the left to import 

scale data.  A screen will appear where you have to choose to import Bulls, Cows or Calves.  

Select the correct target (animal type) based on what data you retrieved from your scale.  After 

you successfully import all data from the file, you can “Exit” or repeat the process to Retrieve 

and Import any other files. 

Gallagher 600/700/800 

The interface with these Gallagher indicators is more intuitive and allows you to select from 

different Trait Forms that are copied from your computer to the indicator before collection of any 

data.  This provides the mechanism to bring that data collected in the field back into Cow Sense 

through Cow COMM.  For detailed documentation on this procedure, click on the Cow Sense 

Trait Tables icon on your desktop.  If you are using Internet Explorer 7 you will see this 

icon .  If you are using Fire Fox you will see this type of icon .  Just keep in mind 

that the name will be similar but the icon picture itself may be different depending on how you 

browse the Internet.  This document was created when you installed the Cow Sense Suite of 

Products.  The data retrieved will be dependant upon the Trait Form used for recording the data.  

Here again it is important 

that you also install the 

software that comes with 

your scale indicator for 

this to work properly.  

Figure 41 displays a 

“Retrieve Scale Data” 

window for the Cow 

Sense Calving Trait table 

available for the 

Gallagher 700 and 800.  

This data can be reviewed 

and edited prior to import 

into Cow Sense. 

Figure 41 Retrieve Gallagher Scale Data via Cow COMM  
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Retrieve EID Data 

Some RFID readers offer a memory that stores the RFID numbers that have been scanned.  For 

the Allflex, Digital Angel and Syscan Live Track readers we offer the “Retrieve EID Data” 

option for retrieving data stored in the reader’s memory using Cow COMM. 

For other readers that have memory you would need to use the software that comes with the 

reader for extracting the data from the reader.  Review any user instructions for the reader 

software for additional guidance.  The software that accompanies your reader (will usually 

generate a text document that can then be imported into Cow Sense using the Import Tool.  For 

further documentation on the Import Tool see page 188 of your Cow Sense User’s Guide or go 

into the Import Tool (Utilities > Transfer Data > Import > Import Tool) itself for further 

documentation. 

Retrieve Data 

1. To “Retrieve” EID Data from the Allflex, Digital Angel or Syscan Readers: 

set up the connection between Cow COMM and the reader as described earlier 

on pages 9-10. 

2. Connect the reader to your computer with the cable that would have been 

shipped with your reader. 

3. From the Cow COMM Main Menu select Activity > Retrieve EID Data.  

The following Retrieve EID window will appear.  (see Figure 42) 

4. Click the “Retrieve Data” Button.  (Make sure that the reader is turned on for 

Cow COMM to be able to pull the data from the reader.)   

5. The RFID data will be retrieved and displayed as in Figure 43 below. 

Figure 43 Retrieved EID Figure 42 Retrieve EID via Cow COMM 
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Save Retrieved Data 

The “Save Data” function allows you to output a text file that can be printed or edited and 

imported back into Cow Sense using the Import Tool.  TAKE NOTE OF WHERE YOU SAVE 

THE FILE SO THAT YOU CAN EASILY LOCATE IT AGAIN!  For further documentation on 

the Import Tool see page 188 of your Cow Sense User’s Guide or go into the Import Tool 

(Utilities > Transfer Data > Import > Import Tool.  Click the Help Button for further 

documentation.) 

Mark Records 

The “Mark Records” function is designed to allow you to retrieve Scanned RFID records from 

the RFID reader, match them up to the RFID’s stored on the animal record in Cow Sense and 

Mark or flag those records.  This is particularly useful if you want to generate a list of cattle that 

were processed, shipped, or received a mass treatment.  Once “Marked” in Cow Sense you can 

retrieve marked records.  Should you choose to mark the records you will be asked if you wish to 

clear the existing marked records (if any) before marking the ones just downloaded from the 

reader. 

Clear Reader 

The Clear Reader function provides you an easy way to erase or clear the memory of the RFID 

reader.  Once you click Clear Reader, all RFID’s will be removed from the reader.  Use caution 

to ensure you have saved the downloaded data or marked the records in Cow Sense to which the 

RFID list pertains.  Another hint is to clear the reader before beginning each day’s work or 

session, especially if you are planning to use the mark records function for entering other data on 

a record in Cow Sense. 

Exit 

Your last option is to “Exit” which closes the “Retrieve Data” window. 

Help Functions 
The Cow COMM Help Menu has three main functions as discussed below. 

Cow COMM User’s Guide 

This document is available in a Portable Document Format (PDF) and launched from the Cow 

COMM Main Menu Help > Cow COMM User’s Guide.  You must have Acrobat Reader 4.0 or 

higher (a free program) to view this document.  You may print this document or access it in this 

fashion.  In the PDF form you can use search functions in Acrobat Reader to find specific topics 

of interest. 



Cow COMM Version 3   

 

40

Update Cow COMM 

The auto update feature of the Help Menu provides a very simple and easy way to update your 

Cow COMM program if you have Internet access to the computer on which Cow COMM is 

installed.  Occasionally, some firewall or Internet security issues block this type of update.  If 

you experience this, try turning off your firewall or Internet security.   

a. Open a connection to the Internet. 

b. Launch Cow COMM. 

c. Go to Help > Cow COMM Support > Update Cow COMM > Yes (to 

Retrieve Update via FTP) > Launch MicroFTP > Connect.  This process 

will download the most current version of Cow COMM from our FTP site. 

d. At the end of the download, you will be notified that the session was complete, 

click “OK”. 

e. Upon clicking “Exit” in the Connect window, a message will be displayed 

indicating that the “File transfer was successful and to proceed with the 

update”, click OK. 

f. A “WinZip Self-Extractor window will open and you will need to click the 

“Setup” button for the update to run.  A “Setup succeeded!” window will open 

and you will click “OK”. 

About Cow COMM 

If you select Help > About from the Cow COMM Main Menu, an About Cow COMM message 

box will appear.  This message box contains the Cow COMM version number, the Cow Sense 

serial number, the Cow COMM registration number, and the support phone number, e-mail 

address and web address.  Select the OK button when you are finished viewing this screen to 

exit. 
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Figure 44: Advanced Features to Cow COMM 
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Advanced Features 
 

As discussed earlier, there are more 

advanced features available to power users 

that may have special application to your 

use of Cow COMM.  Both Auto Sort and 

Cow COMM Pro add some sophisticated 

tools to the standard Cow COMM 

features. 

Figure 44 shows a decision tree that you 

may follow to determine if either of these 

products have application to your operation.  

As these will not have application to all 

Cow COMM customers, these advanced 

features may be purchased separately and 

their functionality is discussed in this 

section.  By all means, if you have any 

questions on use of these tools please 

contact us toll free at (800) 584-0040 or e-

mail: info@midwestmicro.com.  

Auto Sort Function  

The Auto Sort features of Cow COMM 

offer you powerful tools to automate chute-

side decision-making based upon objective 

predetermined criteria.  This process is an 

advanced feature of Cow COMM.  This 

automated function is currently only 

available for processing calves.  As the 

name implies this capability provides the 

ability to pre-designate sort criteria based 

upon existing data and data being collected 

to automatically sort the animals to the 

criteria.  Application of the auto sort can be 

used to sort calves into like groups based 

upon this information.  For example if you 

retain your own replacement females, you 

could define minimum performance criteria 

that is acceptable.  If this function were 

turned on while processing calves, any data 

updated or previously recorded to the 

animal’s record could be used to 

automatically make the sort call chute-side, 

based on the criteria you had impossed.  As 

this is an advanaced feature there is an 

additional charge for this functionality.  
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Figure 45: Define Groups 

 

Charges are assessed for each animal record sorted.  Please call toll free at 800-584-0040 for 

current pricing on Sorts.  There are 200 Auto Sort licenses included with your Cow COMM 

purchase, so it is like getting 200 sorts free! 

Defining Groups (done in Cow Sense) 

Auto Sort allows you to sort your calves into the calf 

groups or the yearling groups you defined in Cow Sense 

(Cow Sense Main Menu > Enter Data > Define 

Groups).   If you would like to modify these groups, you 

must do so by editing the Define Groups section in Cow 

Sense, and then restarting Cow COMM so that the 

changes in the groups take effect (see Figure 45). 

Enabling Auto Sort 

From the Cow COMM Main Menu, select Activity > 

Process > Calves.  This section of the Functions tab enables the use of the powerful Auto Sort 

capability of Cow COMM.  Figure 46a and 46b shows the radio buttons that allow you to choose 

whether or not to implement the auto sort function for calves.  Note the number of sorts you have 

remaining in your Auto Sort license is displayed here as well.  If you want to sort your calves 

using Cow COMM at this time, select Yes and proceed to define the balance of your Work 

Settings as described previously on pages 14-17. 

When Auto Sort is activated it allows you to define the criteria by which you want the cattle 

sorted.  You define up to four different sort groups and an OUT-group.  This allows you to sort 

up to 5 ways.  Once sort criteria are defined, when any information is modified on either Input1 

or the Input 2 tab (that is included in your sort criteria) the Auto Sort function of Cow COMM 

will be triggered.  Auto Sort will assign/reassign the calf to the sort category of which it now 

matches.  The name of the new sort category will appear in the upper right-hand part of the 

screen, and also in the Calf or Yearling Group 1 field (or Calf or Yearling Group 2, depending on 

which group you chose to sort). 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 46a: Auto Sort (OFF) 

 

Figure 46b: Auto Sort (ON) 
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Figure 49: Selecting Auto 

Sort Groups 

 

Auto Sort Function 

If you have fewer than 200 sorts left in your sort license, a “Sort License Low!” message box 

will appear (see Figure 47). 

Figure 47: Sort License Low! 

Once you choose “OK,” regardless of the number of 

sorts you have remaining in your sort license, an Auto 

Sort Fees Apply message box will appear (see Figure 

48). 

Figure 48: Auto Sort Fees Apply 

This box informs you that the Auto Sort Function is 

available on a cost per head basis. Select OK from this 

box.   Notice that the tab that was labeled Auto Sort 

Disabled is now labeled Sort Criteria. 

If you choose to sort cattle in the weaning stage, you will 

choose the calf group (e.g. in the Cow Sense Sample Herd, one 

calf group is Pasture) by which you want to sort your calves.  

If you choose to sort cattle in the yearling stage, you will 

choose the yearling group (e.g. in the Cow Sense Sample Herd, 

one yearling group is Yearling Group) by which you want to 

sort your calves.  Click the radio button to the left of the group 

you want to use (see Figure 49).  Then you will assign one sub-

group (e.g.. a specific pasture or yearling group) to each sort 

category (i.e. the numbers 1, 2, 3 and 4).  Once you choose 

which calf or yearling group you are going to sort by, the sub-

groups will appear in the drop-down lists next to each sort 

category (click the Hot buttons  to view the drop-down 

lists).  From these lists, choose the sub-groups into which you 

wish to sort your calves. 

Sort Criteria Tab 

Figure 50: Sort Criteria Tab 

This feature allows you to customize sort criteria by which you sort 

your calves.  The numbers 1-4 refer to the sort categories that you 

specified in the Settings tab.  Each sort category has “specs,” or 

specifications, that you must define for the Auto Sort function to 

assign your calves appropriately. 

If a calf meets certain “Specs” or requirements, which you have 

defined, for a particular sort category, it will be assigned into that 

category.  If a calf does not meet all of the requirements set by you, it 

will be excluded from that category. 

It is critical to understand that the process of sorting your calves into categories is progressive.  

That is, Cow COMM will first use your defined criteria for sort category 1 and will see if a 

particular calf fits into that category.  If it does, Cow COMM will assign that calf into sort 
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category 1.  If it does not, Cow COMM will compare its information with the criteria defined for 

sort category 2.  If the calf does not meet the requirements for any of the defined categories, it 

will be put into an “Out” category.  So, functionally there are 5 sort categories: categories 1-4 

and “Out.” 

Please note that if a calf meets the criteria for more than one sort category, it will be placed in the 

sort category that numerically comes first.  For example, if a calf meets the defined 

specifications for sort categories 1 and 3, it will be placed in sort category 1. 

It is therefore necessary to be as specific as possible when defining your sort categories and to 

make sure that your sort categories are mutually exclusive in their definitions.  Please note that 

Cow COMM provides the user the ability to enter applicable data chute-side and include it in the 

immediate sorting decision.  See the Calves > Working Calves Screen > Input 1 Tab section 

for more details. 

Defining Specifications for Sort Categories 

To define the criteria that must be met for a calf to be sorted, select the Spec button immediately 

to the left of the sort category that you would like to customize or define.  A Sort Specifications 

for Calves screen will appear (See Figure 51). 

Figure 51: Sort Specifications for Calves 

The “Defining specifications for Sort Categories” 

function in Cow COMM is very similar to the 

“Select” function in Cow Sense.  Please refer to 

page 94 of the Cow Sense User’s Guide for more 

detailed instructions on that function. 

To begin specifying your sort criteria for a 

particular sort category, you need to select the Hot button  from the Sort Specification for 

Calves screen.  A drop down list will appear containing all of the possible fields available from 

the Cow Sense program.  You need to choose a field with which you want to start defining your 

sort criteria. 

Cow COMM will then display boxes to enter an operator (e.g. “Begins With,” “Equals,” or 

“Contains”), a value (e.g. “200,” or “h”) and a logical operator (i.e. “and”).  Selecting the logical 

operator “and” opens a sort field for the next criterion.  Cow COMM allows you to choose up to 

five total sort criteria using the logical operator “and.” 

Figure 52: Sort Specifications for Calves 

Once you have completed defining the criteria for a 

sort category, select OK to save these settings. 

Once saved, they will appear on the Sort Criteria 

tab, in red, next to the sort category number they 

are defining. 

Select the Clear Spec button at any time to reset 

sorting criteria.  Select the Cancel button at any time to exit the Sort Specification for Calves 

screen. 

Cow COMM will save the user defined specifications for each sort category.  That is, the next 

time you open Cow COMM, the “specs” defining the sort categories will be the same as they 
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were at the time Cow COMM was last closed.  When you re-open Cow COMM, however, you 

will still have to select Yes to the "Enable Auto Sort?" section of the Functions tab.  You will 

therefore be reminded, every time you want to sort cattle, of the Auto Sort License Agreement. 

Example of Custom Sort Use 

Set Up Specs (Criteria) 

An example of a situation for using the Auto Sort function would be a scenario for selecting 

replacement females.  For management purposes, you may want to separate out your 

replacement heifer candidates from the rest of their cohorts or contemporaries in the herd.  In this 

example, you would define a sort category that will contain only replacement heifer candidates, 

or replacements, from the Yearlings stage. 

In the Settings tab, select “Yearlings” from the Stage section.  Then select the Cohort group of 

calves that you will be processing from the Hot button  at the right of the Cohort dates 

available.  In the Auto Sort section, select Yearling Group.  Then click the Hot button  at the 

right of the sort category field to access the dop-down list, and select Replacements. 

In this scenario the operator had previously decided that all heifers having an adjusted pelvic 

measure greater than 200 cm
2
, an adjusted birth weight ratio less than or equal to 100, and an 

adjusted weaning weight ratio greater than or equal to 100, should be included in this 

Replacement category.  This is an example of the criteria that must be defined or specified on the 

Sort Criteria tab. 

Select the Spec button for sort category 1.  The first item you choose to set the criteria for this 

sort category is the “sex” field.  Your operator is “Equals” and your value is “h.”  You then 

choose the logical operator “and” to open the next sort field.  (See Figure 53) 

The next criteria you choose is: “Adj Pelvic Measure,” “is greater than,” “200,” “and.” 

The next criteria you choose is: “Adj Ratio BW,” “Is Equal or Less Than,” “100,” “and.” 

The last criteria you choose is: “Adj Ratio WW,” “Is Equal or Greater Than,” “100.” 

Figure 53: Sort Specifications for Calves - Example 

All of the calves that meet these criteria 

will be placed in this sort category.  All of 

the calves which do not meet these criteria 

will be put in the “Out” sort category 

(because none of the other sort categories 

have been defined to include any calves). 

 

Confirm Work Settings 

When you have completed filling out the Functions tab, the Settings tab, and the Sort Criteria 

tab, select OK on the Work Settings screen (see Figure 20).  A Verify Work Settings message 

box will appear.  If the settings are correct, select OK.  If they are not correct, select Cancel, 

make any necessary corrections, and then repeat the verification step. 
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After you select OK on the Verify Work Settings message box, and OK on the Verify Auto Sort 

message box, a Verify Date message box will appear.  You can then process calves, collect data 

and use it to objectively sort the calves into like groups 

Sorting Calves 

The sort function is automatically triggered in Cow COMM, when any of the following events 

occurs: 

1)  Upon reposition, i.e., when you move to an animal’s record 

2)  Upon changing specific data for these fields only: 

 Weight 

 Hip Height 

 Pelvic Area. 

3)  Clicking the red Sort button.  When Auto Sort is enabled the “Save” button transforms to the 

“Sort” button.  Clicking on the “Sort” button makes it become the default and enables the Enter 

Key on your keyboard.  On subsequent animal records you can simply touch the Enter Key on 

your keyboard to repeat the Sort function. 

Changes to other fields may affect sort results but not trigger the Auto Sort.  It is always a good 

idea to select the red Sort button after new information has been entered on either of these Input 

tabs.  Selecting the Sort button will trigger Cow COMM to analyze the new information and 

assign/reassign the calf into the new sort category. 

The Auto Sort not only sorts the calves into groups for you but it also will give you a running 

count, gross weight and average weight for those in each sorted group (see Figure 54).  This is 

very helpful when loading trucks and you need to know how much weight and number of head 

going onto a truck or pen.  In the enlarged portion of the picture in Figure 54, you see that the 

“Final Status” Group “Keep Bull” that there are 11 head, the gross weight is 11,005 lbs and the 

average weight is 1100.5 lbs.  This view will change when the group changes for a calf that sorts 

into a different group. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 54: Group Tally 

     

Figure 55: Auto Sort Score Board 
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Auto Sort also displays a Score Board (see Figure 55) of all groups of which at least one calf has 

been sorted.  In addition a grid will appear displaying the number of calves (Total), number with 

weights (Wt Count) gross weights and average weights for the group.  With this display you will 

always have a running tally of the status of your groups being sorted. 
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Figure 56 ADG Display Options 

 

Cow COMM Pro 

Cow COMM Pro is an upgrade to Cow COMM that can be purchased to provide advanced 

features for customers that desire to apply these capabilities in their chute side decisions.  Cow 

COMM Pro features are available in Version 3.2 or higher.  Update Cow COMM from the Help 

Menu > Select Cow COMM Support > Update Cow COMM (see page 4 of this document for 

further instruction).  Cow COMM Pro has new features that will enhance use of your cattle 

performance records.  This section describes these features and their application. 

Setup Menu 

Chute-side Devices 

Set up of the chute side devices will be the same process as in the standard Cow COMM 

program.  See pages 9-15 of this document for a review of this process. 

Activation 

Cow COMM Pro does require a different activation key from the standard Cow COMM 

program.  When you purchase the upgrade to Cow COMM Pro, you will be provided your new 

activation key.  To activate Cow COMM Pro, launch Cow COMM and from the main menu 

Select > Activity > Activate.  Type in the new key provided.  You will need to restart Cow 

COMM and the new key will take effect and provide the Pro features described in this section. 

ADG (Average Daily Gain) Display 

The ADG Options available in Cow COMM Pro 

provide you the ability to choose how you would 

like the Average Daily Gain to be calculated and 

displayed on the processing window in Cow 

COMM Pro.  From the Cow COMM Pro Main 

Menu Select > Setup > ADG Display.  The ADG 

Options screen will appear as shown in Figure 56. 

These options allow you to choose from Last 

Weight recorded, 1
st
 Weight recorded, First Test 

Weight or from Previous Wt Date (a weight taken 

on a specified date.) 

Activity Menu 

As with the standard Cow COMM program, you will select the type of cattle you intend to 

process.  See pages 15-17 of this document for a review of this procedure. 

Processing Calves 

The processing calves screen is very similar to the standard display in Cow COMM.  It has a 

Setup Tab as well as Input 1 and 2 tabs.  However there are slight differences that provide the 

Pro user some tremendous advantages. 
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Figure 57 Weight Option Feature of Cow COMM Pro 

 

Figure 58 Processing Calves 

 

Setup Tab 

Hip Height Option 

Note the Setup tab in Figure 57 now has an option to select Hip Height Option.  You can choose 

between a Weaning and Yearling Hip Height Measurement.  The user can select the hip height 

measurement to be taken and Cow COMM Pro will store it appropriately in the measurements 

table. 

Weight Option 

Note the Setup tab in Figure 57 now has an option to select the Weight Option.  This is 

particularly useful function for collecting multiple weights on calves through a test period.  You 

can select the weight to be taken and Cow COMM Pro will store it appropriately in the 

measurements table.  The ADG Option selected in the Setup Menu will use this information to 

display the ADG in the upper right hand corner of this screen. 

 

 

 

 

 

 

Input 1 Tab 

The Input 1 Tab in Figure 58 reveals the additional features available to the Cow COMM Pro 

user.  Particularly note the Measurement History Display in the lower left corner, and Summary 

Display in lower right corner. 

 

 

 

 

 

 

 

 

 

 

 

 



Cow COMM Version 3   

 

50

Figure 59 Print EID display 

 

Print EID 

Navigation and use of the Command Buttons is the same 

as with Cow COMM, with one exception.  The “Print 

EID “ button is functional in Cow COMM Pro.  This 

command is used to print a label as displayed in Figure 

59.  Please note the 15 digit EID is displayed as a bar 

code, with the numeric representation printed below.  The 

animal’s primary ID is printed to the lower left and the 

date printed to the lower right.  This feature is 

particularly useful when collecting blood, fecal, tissue and other samples from animals.  This 

feature allows you to print labels that can then be applied to the sample container.  This feature is 

common in all processing screens (calves, cows or bulls). 

Historical Measurements 

One of the most popular features that Cow COMM Pro provides is the ability to collect and store 

key measurements taken on an animal over its lifetime.  When a measurement is taken in Cow 

COMM, it overwrites any previously recorded data and is stored on the animal’s record in the 

Cow Sense database.  However, Cow COMM Pro retains those previous measures in a Historical 

Measurements Table.  This information is displayed in a grid on the Cow COMM Pro screen.  

For calves, the chart appears on the lower left hand side of the Cow COMM Pro screen (see 

Figure 58).  A small chart will display the previous measurement data taken on an animal.  This 

feature is particularly helpful if you wish to retain and compare information about that animal 

over time.   The data for calves that will be logged in the repetitive measures table of Cow 

COMM Pro appear below in Table 3. 

Table 3.  Repetitive calf data fields logged by Cow COMM Pro 

Weight Hip Height Scrotum (bulls only) 

Muscle Score Pelvis Area Back fat 

IMF REA  

Note that dates for each of the measures above will also be recorded.  Average Daily Gains for 

weights taken is logged as well.  For calves, there is also, a “Summary” box (to the right of the 

Measurement History grid that displays the changes since the last data was collected. 

If you are currently using the standard version of Cow COMM version 3.2 or higher and choose 

to upgrade to Cow COMM Pro any previous data collected (in version 3.2) will then be 

displayed in the Measurement History grid. 

Process Cows 

The Working cows screen is also very similar to the standard Cow COMM (see Figure 60).  Note 

the main difference is the Print EID command button and the Measurement History grid. 
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Figure 60.  Process Cows Screen 

 

Figure 61 Process Bulls Screen 

 

 

Print EID 

The print EID feature is the same function 

as with Working Calves described 

previously on page 50. 

Historical Measurements 

As with the Processing Calves screen, 

Cow COMM Pro provides the ability to 

record and retain individual measurements 

in an historical grid.  For cows and bulls, 

the chart appears on the right hand side of 

the Cow COMM Pro screen.  This 

scrollable grid will display the previous 

measurement data taken on an animal.  

This feature is particularly helpful if you wish to retain information about that animal over time, 

providing you the ability to compare such measures as Body Score Condition codes, Udder or 

Mouth Scores from year to year (or whatever measurement frequency your management 

dictates).  The measurement data for cows that will be logged in the repetitive measures table of 

Cow COMM Pro appear below in Table 4. 

Table 4.  Repetitive cow data fields logged by Cow COMM Pro 

• Weight • Mouth • Condition 

• Udder Score • Hip Height • Preg Status *1 

• Pelvis • Frame Score  

*1 - Note that if you select only Bred or Open, Bred or Open will be displayed, if Days are entered, Days will be displayed in the grid. 

Note that dates for the measures above will also be recorded.  Average Daily Gains for weights 

taken is logged as well. 

Process Bulls 

The Process Bulls screen appears and 

functions like the Processing Cows 

screen (see Figure 61 Processing Bulls).  

The only difference is the historical 

measures grid.  The measurement data 

for bulls that will be logged in the 

repetitive measures table of Cow 

COMM Pro appear below in Table 5. 

 

Table 5.  Repetitive bull data fields 

logged by Cow COMM Pro 

• Weight • Scrotum 

• Hip Height • Pelvis 

 

Note that dates for the measures above will also be 

recorded.  Average Daily Gains for weights taken is 

logged as well. 
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Sorting the Measurement History Grid 

The information can be sorted one of two ways, by Date or Type.  To sort by Date or Type just 

click on the data in the date or type column (not the Headers). 

Retrieve Measurement Data 

Having the historical data available for advanced chute-

side decision-making is great… but how do you get at it 

for advanced analysis?  From the Main Menu Select > 

Activity > “Retrieve Measurement Data”.  This 

function allows you to export data from Cow COMM 

Pro’s historical measurement table out to a text file that 

can be opened with Microsoft Excel, Access or any 

other analytical tool that can convert a text file.  You 

can select a specific Date Range or All Records.  In 

addition you can select the Output Style, either Series 

or Grid.  With the Series Output the data will appear 

chronologically by date.  Alternatively the Grid Output 

will display the data sorted by animal ID and the 

measurement data in columns to the right.  Once you 

have made your selection click “OK”(see Figure 62). 

A “Save Measurements to File” window will appear 

(see Figure 63).  Enter a name for the file by simply 

typing over the wild card character (*), leaving the 

.txt extension.  By default, the file will be exported to 

C:\CowSense\Export folder unless you specifically 

direct it to be saved to another location.  Then click 

“OK”, you will receive a message that the data was 

exported successfully.  Now the file can be opened 

from Excel, another spreadsheet application or any 

software that can convert a text file. 

 

Figure 62.  Input Date Range 

window. 

 

Figure 63.  Save Measurements to file 

window. 
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Conclusion 

Cow COMM allows for unprecedented real time use of the Cow Sense data while working cattle.  

Whether collecting data, sorting cattle or both, Cow COMM provides you powerful new tools for 

positioning your operation for profitability.  You can count on us to continue offering products on 

the leading edge of technology for the beef industry.  Our promise to you is simple and a part of our 

company mission: Midwest MicroSystems is dedicated to improve the economic position and success 

of our customers by providing the most current, superior quality, integrated information 

management solutions.  This release of Cow COMM is continued evidence of that commitment. 

This is the third general release of this product and development continues to enhance its user-

friendliness and to introduce additional features.  Like Cow Sense, Cow COMM is designed and 

programmed for beef producers by beef producers.  That inborn appreciation of our industry and 

the challenges we face provides us the ability to understand cattlemen’s needs and incorporate 

their input.  This combination of highly competent technical skills and beef production expertise 

provides an unparalleled ability to design products that efficiently and effectively meet the needs 

of the industry.  We are hopeful that this product becomes an important part of your management 

tools.  We welcome your suggestions and comments as to future enhancements.  Please feel free to 

contact us at (800) 584-0040, or e-mail info@midwestmicro.com. 


